Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have a string in French but WPML thinks it is in English.

Relevant Documentation: https://wpml.org/2015/10/wpml-makes-it-easy-to-run-sites-without-english/ Section: How to set the source languages of strings

This topic contains 2 replies, has 2 voices.

Last updated by christopher-3 2 years, 2 months ago.

Assigned support staff: Otto.

Author Posts
December 21, 2017 at 8:40 pm #1464097

christopher-3

Hello Otto

I have translated my home page, it works fine except for the search button of booking form plugin
The URL is not translated even though I did it.
Could you check what s wrong please

December 22, 2017 at 12:03 am #1464148

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello 🙂

The problem here seems to be that the URL is assumed to be in French. Check the flag near the string. Even the URL is pointing the English page, it is French for WPML, so you are translating it to Anglais.

The solution is simple, select the string, and at the bottom of the table, you will find a button to change the language of the string.

Set it to English, and translate it to French.

Check this documentation please:
https://wpml.org/2015/10/wpml-makes-it-easy-to-run-sites-without-english/
Section: How to set the source languages of strings

Let me know if my explanation was clear and if it worked for you.

Kind Regards,

Otto

December 22, 2017 at 4:04 am #1464185

christopher-3

Otto is very helpful