This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 3 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 17, 2018 at 11:07 pm #2742762

shaneM-4

I am trying to: Fix my client's website

Link to a page where the issue can be seen:

I expected to see: Load times under 5 seconds

Instead, I got: Load times around (or over) 20 seconds

September 18, 2018 at 2:55 pm #2745553

shaneM-4

Would you mind making the website above a private link? Thanks!

I've had some success getting the site down to about 8 second load times by clearing some of the string translation data. I was also having an issue with the site loading twice while automatic country redirect was enabled. I'd like to get this site load time down to less than 4 seconds if possible.

Thanks!

September 19, 2018 at 12:14 am #2746749

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Have you followed the steps in our documentation to improve the performance of your site? If not, you can see the step by step here: https://wpml.org/2012/01/can-your-site-run-faster/

Also, depending on how many strings your site has, this can impact performance a little bit. As a suggestion, you can remove strings that are not translated. To do this, please follow the steps below:

- Click on the WPML > String Translation
- Scroll down and look at the "Auto register strings for translation"
- Click on the "Edit" button
- Uncheck all strings which you do not want to be automatically indexed
- Click on the "Apply" button

To remove all strings that are not translated, follow the steps below:

- Make a full backup of your database.
- Open your database manager (you can use PHPMyAdmin, for example)
- Select your database
- Open the "_icl_strings" table and click on the "SQL" tab
- Run this command:

DELETE FROM `wp_icl_strings` WHERE `status` = 0;

* In the above command I'm using the database prefix "wp_". If you have changed this, you must edit the prefix for what you are using.

This will remove all strings that are not translated. If you need to translate some string that was deleted, you can scan your theme/plugin again in WPML > Theme and plugins localization.

By following these steps, does this help improve performance?

Thank you.

September 19, 2018 at 3:42 pm #2749336

shaneM-4

I'll review these methods. Would you mind making the screenshot above private as well?

I have cleared strings from the site. I'm not seeing any problematic queries either, other than icl_strings running 6 duplicate queries. Site load time is down to 8 seconds which is better than it was, but could still be significantly improved.

Thanks!

September 20, 2018 at 6:16 am #2750887

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

As requested I removed the screenshot too. As you followed the above steps, we may need to look at your site to see what may be happening.

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 25, 2018 at 6:25 am #2762577

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Sorry for the delay. I'm still checking your site and soon I'll contact you.

Thank you.

September 27, 2018 at 7:39 am #2769590

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Bruno is currently offline

please verify with me if you were ever able to test the following steps
https://wpml.org/2012/01/can-your-site-run-faster/

Additionally if possible please test with a minimal environment and WPML activated , what are your results ?

October 8, 2018 at 2:47 pm #2796472

shaneM-4

Hello,
I was able to test with the steps above. They helped a little but my load times are still extremely slow. Bruno was going to login and take a look under the hood. Are you willing to do that Bobby?

Thanks!

October 9, 2018 at 5:47 am #2798308

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. Unfortunately, I could not replicate the problem you are reporting with WPML.

When I disable WPML and its add-ons and look at browser load time, it looks like the loading time is basically the same, between ~13 and ~15 seconds.

With WPML disabled, does your site perform better? All the tests I did were on the homepage.

Thank you.

The topic ‘[Closed] Solidscape site is loading EXTREMELY slow’ is closed to new replies.