This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.52 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by Radu 2 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
July 16, 2019 at 6:38 am

zikriD

I am trying to: Using ACF on all translated page

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: We supposed can select the date and do booking. But on Malay & Chinese page, when I click the date to booking, there's a popup mention that the golf course not available for booking. This occurred on all accommodation.

July 16, 2019 at 7:27 am #4217079

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for reaching out the WPML support!

I just checked the Malay translating and I could see that it's a duplicate. The Chinese translation (which is not duplicate) seems to work fine (I can select the date). Can you tell me if the date selector from the Malay version is working if you translate it instead of duplicating it, please? Also, what's the field from the Accommodations group that's connected to the calendar? I want to have a look at it and see what's going on.

Thanks,
Radu

July 16, 2019 at 7:55 am #4217263

zikriD

Hi,
Thanks for fast response. I already changed the Malay page to translate, but still not working. Chinese page also not working well, we can select date, but then cannot select the session slot(next to date selection field). The date selector can be set at the custom field area as shown in attached image. Please help to check. Thank you.

July 18, 2019 at 8:30 am #4236003

zikriD

Hi,
Do you have any feedback on this? Thank you.

July 18, 2019 at 8:49 am #4236177

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I was looking at this issue right when you wrote the last message. Can you tell me if you made any changes to the accommodations lately? I'm asking this because I was trying to edit the English version of the Horizon Hills Golf accommodation and just two elements are loading (yesterday everything worked fine and I thought that this is just a temporary issue).

Thanks,
Radu

July 18, 2019 at 9:07 am #4236379

zikriD

Im accidentally overwrite the file in cpanel...will revert it in 10minutes

July 18, 2019 at 9:12 am #4236515

zikriD

Please help to check again. I just repair the website. Thanks

July 22, 2019 at 5:45 pm #4260527

zikriD

Hi,
Any update on this? Thank you.

July 22, 2019 at 8:11 pm #4261093

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I didn't forget about this ticket. I checked the accommodations a few times today, trying to figure it out why is the behavior different in secondary languages. I was able to find that the date field is created here hidden link. Did you add any rule of setting that's showing a message if the date selected is not between the available from and available to dates? I want to check if there's something different set for these values on the secondary languages.

Thanks,
Radu

July 22, 2019 at 11:48 pm #4261719

zikriD

Hi,
I'm not sure why you just found it after 6days. I already mentioned in my 1st post that I'm setting the ACF. I believe the setting is in the file mention below. Please help to check soonest possible. Thank you.

public_html/wp-content/themes/Travelo-child/single-accommodation.php
public_html/wp-content/themes/Travelo-child/available.php

July 23, 2019 at 8:46 pm #4268861

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I checked the child theme a bit closer (that's why it took a bit longer to come back with an answer) and it seems that the file where the check for the date is made is called 3ilogics_custom.js. Here, the function that's doing the check is called dateChanged. I checked it a bit and it seems that the value assigned to the seldate variable is not correct. This is why the check from line 400 is not passed and the error message is displayed.
The changes made in ACF are working fine and the elements are displayed well, as you can see. The part that's not working is the custom code from the child theme and I'm afraid that this is something I cannot help you with. I made this little check to give you some help about what's the part that's causing this message to be shown but you're the one that needs to continue debugging it and find what's the code that will make everything work fine.

Thanks,
Radu

July 24, 2019 at 12:08 am #4269319

zikriD

Hi,
Thanks for your reply. Just want to check, did you do any changes to any files?
The other thing is, if just like you said the error coding on seldate, then why there's no issue in English version? Only issue is when we change the language?
Please advice. Thanks.

July 29, 2019 at 7:06 am #4297265

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I didn't do any change to the code from your website the last time I checked this out. I had another look at the custom JavaScript code in the last few days but I couldn't find the reason why is it working different on each language. There might be some other JavaScript code that's editing the save variable. If you check the value of seldate from line 364, you can see that it gets undefined on different places of that functions, which makes me think that some other code is changing it. As a test, you can try to change the name of the variable (since it's used on other places of this file too), or you can try to deactivate all the plugins and see if things are back to normal (thinking that maybe this variable is changed by the code of one of the plugins you're using).

Thanks,
Radu

Thanks,
Radu

The topic ‘[Closed] Some ACF Function Not Working On Translated Page’ is closed to new replies.