This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 10, 2019 at 4:27 pm #4182587

lottaS-3

I am trying to: The default language is English (Great Britain) and all the menu links show the full content. The Swedish page also shows everything, but the other countries do not show one of the product groups.

Link to a page where the issue can be seen: hidden link

I expected to see: Clicking on Watch Straps I want to se the products. Only the Watches are showing (except for Great Britain and Sweden were everything is visible)

Instead, I got: Broken content

I would be grateful for som advise. // Lotta

July 11, 2019 at 1:31 am #4184975

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 11, 2019 at 8:15 am #4187245

lottaS-3

Hi, the site is going through a backup restore at the moment. I will get back to you when it is finished. Thank you for waiting. // Lotta

July 11, 2019 at 11:19 am #4189111

lottaS-3

Hi Marcos,
rumoe.com is up and running again so if you have time to help out it would be great!
// Lotta

July 12, 2019 at 1:23 am #4193941

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Lotta,

Thank you for the provided details. I took a detailed look in your website and noticed your homepage actually only have a swedish translation, so it is really weird the fact the other languages show content even with no translations on place and your additional languages hidden, here it seems we have some cache interfering in your website.

Can you please, test it with your cache plugin, any possible server side and browser cache disabled? When there's a missing translation and you set your 'How to handle languages without translation' option to 'Link to home of language for missing translations' from your WordPress Dashboard > WPML > Languages > Language switcher options the expected behavior should be the default language content to be shown, exactly the behavior you expect, in your case as said above, I believe some cache is interfering here, this is why it is important to proceed with the confirmation regarding it, performing my requested test above. Please, let me know the results, have a nice day.

July 12, 2019 at 1:15 pm #4199195

lottaS-3

Hi Marcos, I cant see my last message so I re send and add an image. In an old dev site it works and there it looks like the screen shot where everything is light green. In our sharp version all active languages have a lot of labels in different colors. I want to go back to the "light green version. How can I do this? Pleas take a look at the images. Best regards. // Lotta

July 12, 2019 at 6:29 pm #4201077

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. The screenshot shows the WPML Meny Sync in action, the different colors shows what happened to your menu during the sync action. Most likely you edited your menu and then performed a sync operation, in this case if you removed a menu item from one language it also was removed in the other languages of your website, the same happens for menu added, reorded and so on. You can read more regarding it at: https://wpml.org/documentation/getting-started-guide/translating-menus/#option-2-automatic-menus-sync-by-wpml. Please, let me know if you need any further details and clarifications, have a nice day.

July 12, 2019 at 6:42 pm #4201141

lottaS-3

I did the cash as you suggested but it did not work.

July 12, 2019 at 6:44 pm #4201151

lottaS-3

Thank you very much. I will follow that document and I hope it will solve my problem. // Lotta

July 12, 2019 at 7:31 pm #4201399

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

July 13, 2019 at 8:24 am #4203131

lottaS-3

Hello, now I have migrated the site. I have also tried a few things.
1. I deleted all languages that we do not use to make it easier to work.
2. I deleted menu items and tried to add links for each country with the en-au, us, en-ca etc. However, after a few hours these links disappeared and fell back to the default. Like this: hidden link - I created link for Canada hidden link but it changed back. The only country that kept the link is Australia.

I want the same menu for every country except Sweden but not fall back to Great Britain since the products need to be shown in the local currancy. It does not work anymore.
I want the Watch Straps Products to show. The are gone, just the Wathes Collection shows. It works fine for Sweden and Great Britain.
Thanks. // Lotta

July 15, 2019 at 12:35 pm #4211009

lottaS-3

Hello, Good Morning!
Have you managed to find out why Watch Straps and menues are not showing and why the us, en-ca, global and eu don't work. I would be very very happy if you could solve the problem.

July 16, 2019 at 12:38 am #4214865

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bif of waiting here. I am jumping here to let you know I am current working on your issue and I will provide you with a detailed and accurate answer in the next hours. Thank you for your continued patience and unerstanding, have a nice day.

July 17, 2019 at 2:05 am #4224857

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a reply. After a detailed look I noticed the cause of your missing translated content (in your case the Watch Straps) seems to be related the fact you actually didn't have translations for the 'straps' category from your WordPress Dashboard > Products > Categories menu. Also, I didn't find a way to give a look in your language switcher settings as it seems to be coming from a custo made language switcher builtin in your theme. Can you please, provide me with some detailed instructions on how to see its settings? It will help me to further investigate it and test it against the WPML default language switcher. Thank you for your collaboration and continued patience, have a nice day.

July 17, 2019 at 4:49 am #4225891

lottaS-3

Hello,

Thank you so far 🙂
This is the strange thing because we don't have translations, we don't want translations for any language except Swedish. The other countries we use speak English and we have the setting "How to handle languages without translation - Skip translation". We never translated them...
Do we have to translate English into English? Or can we delete anything so that VPML stop asking for translations? It work fine until we used the WP menu Sync option, that is when the problem started I think.
The language switcher is a file called rumoe-wpml-fix-links.php. It was written before I started to help the company, and I don't know exactly what it is for. I can send it to you if you give me an email or upload option.
Have a nice day! // Lotta

The topic ‘[Closed] Some content is not showing in some languages’ is closed to new replies.