This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 month, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 20, 2019 at 9:32 pm #3850255

joannaP

We have sent this page through WPML. The content has come back and only some content is showing up translated.

This is the English version: hidden link

This is the Chinese version:
hidden link

I am unable to provide Debug Information. Every time I paste it into the field below your website crashes.

Plugin Name Status Active Version
WPML Multilingual CMS Installed Yes 4.2.6
WPML CMS Nav Not installed No n/a
WPML String Translation Installed Yes 2.10.4
WPML Sticky Links Not installed No n/a
WPML Translation Management Installed Yes 2.8.5
WPML Media Installed Yes 2.5.2
WooCommerce Multilingual Not installed No n/a
Gravity Forms Multilingual Installed Yes 1.5.0
Yoast SEO Multilingual Not installed No n/a

PHP INFO
Version 7.0.33-0ubuntu0.16.04.4
Memory limit 256M
Memory usage 37.97 MB
Max execution time 30
Max input vars 10000
Utf8mb4 charset Yes
Multibyte String extension Loaded
SimpleXML extension Loaded

May 21, 2019 at 4:54 am #3851857

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

So the pages are already translated but not showing on front-end, isn't it?

Could you please follow the below steps and let me know if this helps:

1) Make the translation as complete (100%)
2) Now go to the default language and update the post.
3) Send the post to translation again, this should show all the updated items.

Note: If the steps above don't work, I request you to add something dummy text on the default language and update the translations.

Look forward to your reply.

Thanks

May 22, 2019 at 4:18 pm #3868103

joannaP

Thank you for the feedback. Please see my responses below.

1.) Make the translation as complete (100%)
** DONE, it showing green check marks as "Complete"

2.) Now go to the default language and update the post.
** What do you mean by this? I went to the page that is having this issue and clicked the "Update" button to publish it again.

3.) Send the post to translation again, this should show all the updated items.
** I checked the box for the specific page I'm having issues with, added it to the Translation Basket and sent it out for translation. I then clicked the "Check status and get translations" button and the page still is only partially translated.

Note: If the steps above don't work, I request you to add something dummy text on the default language and update the translations.
** I have no idea what you mean by this??

What else can I do to fix this issue?

May 22, 2019 at 8:59 pm #3869255

joannaP

Also, I checked with the translation company and they verified that the untranslated content was NOT received in the XLIFF using WPML translation services.

May 23, 2019 at 3:43 am #3870985

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Note: If the steps above don't work, I request you to add something dummy text on the default language and update the translations.
** I have no idea what you mean by this??

I was asking you to add some dummy elements on the default language, so this can fix if there are any synchronization issues between the elements and shows in the Translation Editor.

Since the translation service verified that the contents aren't received properly, could you please create a screenshot of the contents that are missing translation?

Further, to debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

The topic ‘[Closed] Some content on a page not translating’ is closed to new replies.