This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by jacekm-7 3 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 9, 2019 at 5:01 pm

jacekm-7

I have checked some box under "string translation" but i do not know it's name in english, and i think this messed things up. I have not created backup of this site.

July 9, 2019 at 7:32 pm #4174081

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Can you please provide us with more details regarding your request? Which strings did you check? What is its text domain? In which place of your website frontend they are displayed? These details will help us to understand your issue and provide you with a detailed and accurate answer. Thank you for your collaboration, have a nice day.

July 10, 2019 at 9:49 am #4177875

jacekm-7

Thank you for replying. i am attaching screenshot. this is the checkbox i have checked and unchecked after a while. After that some of strings in some domains showing on frontend as not translated. Please visit my website at krohmall.pl, at the bottom you can choose english language and everything was translated to english before, now some of text found on homepage show in Polish.

July 10, 2019 at 3:56 pm
July 10, 2019 at 3:57 pm #4182453

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

July 10, 2019 at 7:06 pm #4183995

jacekm-7

Hi Marcos, the migration is ready. Waiting for problem to be resolved.

July 11, 2019 at 7:25 pm #4192865

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took an extensive investigation in your website and noticed the cause of your issue was your 'Localization options' in your WordPress Dashboard > WPML > Theme and plugins localization I uncheck these options:

1 - Use theme or plugin text domains when gettext calls do not use a string literal
2 - Assume that the original language of all strings is English

And now your strings translations are working properly as you can check at: hidden link

See: https://wpml.org/documentation/getting-started-guide/theme-localization/

Please, let me know if you need any other details and assistance, have a nice day.

July 11, 2019 at 9:49 pm #4193213

jacekm-7

My issue is resolved now. Thank you!