Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andreas W. 10 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
January 10, 2019 at 9:20 pm #3078188

camB

I am trying to: set the order as "completed" and be sure the customer receives an email notifying him the order has been completed that is written in the customer's language (and not in English)

Link to a page where the issue can be seen: Test in backend

I expected to see: The customer who bought an item on the German site should get only emails written in German

Instead, I got: The customer who bought an item on the German site will get emails in English if I open the order in the backend and change its status to completed inside the order.

January 10, 2019 at 10:53 pm #3078334

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

Please verify if your settings for E-mails are set in a proper way for their respective language at WooCommerce -> Settings -> Emails.

Did you translate those E-mails with String Translation?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

January 11, 2019 at 9:39 pm #3082016

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I have created a WPSandbox with WordPress 5.0.3. including WPML and add-ons plus WooCommerce and WooCommerce Multilingual at their latest versions.

You can visit the site here by one-click login:

One Click Login:hidden link

A store was created and translated into a second language (German). Then product was purchased from the German frontend and marked as completed on the admins area.

The emails send out have been saved on the backend with the plugin WP Email Catcher, as it is not possible to send out emails form the Sandbox, but it was the only option to share the result with you. The email regarding the product purchased on the German frontend was sent out in German.

The emails can be found at Settings -> Emails Catch All.

I would kindly like to ask you to try if the issue persists when you disable any plugin that os not WPML plus add-ons and WooCommerce plus WCML.

I can still offer you to have a look at your wp-admin for further troubleshooting. PLease let me know if this might be convenient for you.

Kind regards
Andreas

January 12, 2019 at 11:03 am #3083039

camB

Hi Andreas!

What a great idea of you!

I could reproduce the error.

Reproduce Error 1:

To do so, please go under WooCommerce -> Orders -> open the order by clicking on Andreas Walter > under Order #37 details, change the Status to "Completed"

Now check under Settings -> Emails Catch All -> You will see the newest email is in English (instead of German).

Reproduce Error 2:

To do so, please go under WooCommerce -> Orders -> open the order by clicking on Andreas Walter > under Order #37 details, change the Order actions to "Email Invoice / order details to customer"

Now check under Settings -> Emails Catch All -> You will see the newest email is in English (instead of German).

Can you now please have a look at it?

Thank you!

Cam

January 14, 2019 at 10:59 pm #3089949

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I am sorry but I can not follow your explanation. When entering the Orders I accepted the order as purchased but for some reason the order appeared English product with a German Shipping Class, even if I did not declare any shipping class for this article.

I then went to the English store and purchased a new product without any surprises. The email was sent in English. Then I entered the German store and purchased and also this email was sent in German.

I would like to further assist you on this matter but could you please provide a screencast that provides information about how you make the purchase as I made various test purchases and they all were processed correctly?

Please also see the screenshot attached that declares a German Shipping class for an English product. Maybe your error might be caused here. Please verify the shipping classes assigned to your products on your live site.
Shipping lasses do need to be translated at WooCommerce -> WooCommerce Multilingual -> Shipping Classes.

I now translated the shipping class for the test site. Please take note that we can only debug website if the customers agree in order for our support team to verify the issue and to escalate it for further debugging.

Kind regards
Andreas

The topic ‘[Closed] SOME emails to customer are sent in admin language and not in customer language.’ is closed to new replies.