This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Raja Mohammed 11 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 22, 2019 at 7:37 am #4254467

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your patience,

I have made a few more tests and found that, Regardless of the field type. If the value is numeric it will be skipped for translation, However, I did check the length field after updating the field and saving the original product the field is copied perfectly to the translation earlier the field was missing. please refer the screenshot hidden link

I am checking with the second tier for a second thought, I will let you know once I hear from them.

Meanwhile, I would suggest the following steps.

1) In wpml > Settings > custom field translation, regardless of field type Set all the Fields which would have only numerical value to copy

2) Add minor modification to the fields in the product in default language save the product variation and update the product

3) Send the updated product to Lionbridge, The fields that are set to "Copy" and fields with just Numerical value will not appear for translation.

4) Complete the translation and send the translation back to the site, Check if the fields set to copy are updated properly.

I have tested this with the local translator and it works perfect, Let me know the results with the Lionbridge.

Kind regards
Raja

July 22, 2019 at 8:51 am #4255003

reiL

Hi Raja,

Thank you for letting me know. I have passed your details onto the developers and asked them to look into the steps you have provided.

I will let you know how we get on.

Thanks again,
Adrian

July 23, 2019 at 4:42 am #4262619

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure, This would probably solve the issue.

If the issue still persists after following all the steps, I will escalate this to the second tier maybe this is a bug.

Kind regards
Raja

July 23, 2019 at 6:02 am #4262799

reiL

Hi Raja,

We have tried the solution you provided and are still seeing the issue. Further details outlined below.

The developers have made some edits and sent them for translation but this has not had the desired effect. Having looked into the modification that you yourself made, we spotted that you added an extra 'm' to the '160mm' fields. This has shown that:

1) When there are as many letters (or special characters, e.g. spaces, dots, commas etc.) as numbers in the value of the field, or there are more letters than numbers then WPML considers the value as text content and it is sent to translation and it is returned without issue.

2) Also, when the field value starts with a letter followed by numbers, then the number of different characters does not matter and the field is considered as text in any case.

Here are links for you to the latest xliff files after the translations were completed:

hidden link
hidden link

Some examples are below:

"160mm" > will be considered as a number field and won't be returned as copied or translated as there are more numbers than letters.

"160mmm" > will be considered as text and will be sent to translate.

"160 mm" > will be considered as text and will be translated.

"mm160" > will be considered as text and will be sent to translate

Prior to the update the settings we had in place correctly copied or translated the fields as required, therefore it appears that a change in logic has occurred with the last update performed.

Can you please have this looked into more detail as we do feel the latest update has changed the logic from how it was before?

Thank you very much,
Adrian

July 23, 2019 at 10:27 am #4265109

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thank you for your patience and cooperation,

I am able to reproduce the issue with the supplied information, The issue is now being consulted with the second tier of supporters, If this is confirmed as a bug this will be escalated further. I will keep you posted with further updates.

Highly appreciate your cooperation.

Kind regards
Raja

July 24, 2019 at 8:59 am #4271883

reiL

Hi Raja,

Thank you for letting me know.

Please keep us updated on how the fix for this progresses.

Adrian

July 24, 2019 at 12:57 pm #4274705

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Adrian,

Thanks for your patience,

This is expected behavior, I would suggest you please set the fields to "copy" instead of "Translate" or if you wish to translate then as per the measurement standards add the values as '160 mm', with a space between the numeric and alphabet value.

I have tested with other scenarios this seems to be happening with the metrics like mm cm etc.. expected format for metrics is 33 mm 40 cm

I hope this helps you better.

Kind regards
Raja

July 25, 2019 at 5:14 am #4279119

reiL

Hi Raja,

Thank you for the update and details on that.

But prior to the plugin update, this worked correctly in that they would be copied/translated based on the settings we had in place. Now following the updates, some fields and values are not being returned correctly so we would deem this as a bug and we would expect it to work as it did before.

This might be the expected behaviour after the update but it wasn't prior to it so we would prefer that it translates or copies fields in the same way as before the update.

Why has the logic for that been changed as part of this update?

Please discuss that with the team at your end and see what can be done for that.

Many thanks,
Adrian

July 25, 2019 at 5:20 am #4279121

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I can understand your concerns I have raised the issue to the second tier.

Kind regards
Raja

July 25, 2019 at 7:38 am #4280211

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Adrian,

The logic was changed in wpml-translation-management Version 2.7, Since your previous version was 2.6.7 it used to work for you.

The second tier support Sumit helped with the updated ticket, The logic was used to skip the CSS value like cm, px, em, mm, etc.. Which is used along with a numeric value like 60em, 10mm, 30cm etc..

This is not a bug but an enhancement to reduce the translation credits.

I hope this clarifies the issue.

kind regards
Raja