This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 27, 2019 at 3:01 pm

julienT-6

I am trying to: Show all images on translated page (English side)

Link to a page where the issue can be seen: hidden link

I expected to see: All images

Instead, I got: White space

August 27, 2019 at 6:07 pm #4468969

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed lookn in your WordPress Dashboard and could fix the issue, here is what I tried:

1 - I cliked to edit your homepage in the default language.

2 - In the 'Multilingual setup' at the bottom of the page editing screen I click to show the system custom fields, then I set the fields '_image_expertise' and '_image_region' as 'copy'.

3 - Then, I clicked to update the page in the default language page.

4 - As a last step I clicked to edit the translated page as well and update it without making any change, this action make sure the images are copied from the default language page to the translated page.

5 - You can see the results at: hidden link

See: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

Please, let me know if you need any additional instructions and clarifications, have a nice day.