This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 36 replies, has 2 voices.

Last updated by Carlos Rojas 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 18, 2019 at 7:16 pm #4046139

lauriL-5

Hi,

For some reason my deleted sections appear when I am trying to translate my homepage to other languages. These sections had also images. I deleted these images from my media library.

Kind regards,
Lauri Lembit

June 19, 2019 at 6:29 am #4048363

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I kindly ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Go to Plugins -> Add new -> Commercial tab -> Update WPML plugins to the latest version.
- Update any other outdated plugin and/or theme.
- Flush any cache memory that might exists.
- Edit the page in the original language -> Make small change -> Save the changes. (this will refresh the database entry for this page)
- Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps pointed out in the attached image.

Could you tell me if the issue persists?

Kind regards,
Carlos

June 19, 2019 at 6:41 pm #4054031

lauriL-5

Hi,

I followed the steps, but unfortunately it did not fix the problem.

Best regards,
Lauri

June 19, 2019 at 9:52 pm #4054923

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lauri,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

June 21, 2019 at 12:09 am #4063661

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lauri,
Thank you very much for the information provided.

I followed this steps in the site:
- Edited the homepage in the original language -> Made a minor change -> Saved the page

Now the issue seems to gone. Could you confirm that the issue is solved?

Note: Please update the WordPress core and WPML Translation Management plugins to their latest version. Outdated functionalities can cause conflicts in the code.

Regards,
Carlos

June 21, 2019 at 9:31 am #4065771

lauriL-5

Hi,

Thanks but the deleted sections still appear on my homepage. I attached the images of the sections which I have deleted but still appear when trying to translate my homepage.

Best regards,
Lauri

June 21, 2019 at 10:51 pm #4069435

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I took a second look at the site and I kindly ask you to follow this steps:
- Create a full backup of the site.
- Update the Divi theme to its latest version.
- Deactivate Wordfence plugin.
- Flush the cache memory.
- Deactivate W3 Total Cache plugin.
- Edit the homepage -> Make a small change -> Save the changes -> Update the translations.

Could you tell me if the issue persists?
Regards,
Carlos

June 25, 2019 at 10:19 am #4083137

lauriL-5

Hi,

I followed the steps but the problem is still there.

Best regards,
Lauri

June 25, 2019 at 12:58 pm #4084739

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lauri,

In this case I suspect that the issue might be caused for two reasons:
1.- Outdated cache memory.
2.- For some reason the entry in the database for this page still has the images.

I would like to ask you to re-create the page and let me know if the issue persists.
Regards,
Carlos

June 25, 2019 at 7:06 pm #4086931

lauriL-5

Hi,

Should I delete only page content or delete entire page and then recreate it?

Best regards,
Lauri

June 26, 2019 at 10:43 am #4091663

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lauri,

I recommend you to re-create the page from scratch. In this case the best practice is to create a new page, check if the issue disappear and if it does then delete the old page and replace it by this new one.

Regards,
Carlos

June 30, 2019 at 8:56 am #4113695

lauriL-5

Hi,

I created test page of my homepage, tried to translate it from the original language to English and none of the images were shown in translation. I attached images so you can see yourself.

Best regards,
Lauri

July 1, 2019 at 7:13 am #4115955

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I would like to ask your authorization to apply some troubleshooting steps in the site in order to isolate the cause of this issue. I suspect this is caused by a cache memory or a conflict with a third party functionality.

In this case I will need your authorization and your confirmation that a full backup of the site is done, so you can restore the site if necessary.

Regards,
Carlos

July 1, 2019 at 7:44 am #4116165

lauriL-5

Hi Carlos,

I authorize you to make troubleshooting steps on my website and I confirm that I have made the full backup of my website.

Best regards,
Lauri

July 1, 2019 at 9:26 am #4116901

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lauri,
Thank you very much for your authorization.

I took a deeper look at the issue and followed this steps:
- Deactivated the cache plugins and Wordfence plugin.
- WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps.
- Updated Divi theme.
- Added the XML code to map all Divi's shortcodes in WPML -> Settings -> Custom XML Configuration -> Saved the changes.
- Translated the page and I couldn't see the images, however the images are shown correctly in the front end.

Note: In case you need to show a different image in a secondary language you need to translate the image in WPML -> Media Translation.

Could you confirm that the issue is solved?

Regards,
Carlos