This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Itamar 7 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
March 6, 2019 at 7:13 am #3277177

vaidaK-2

I am trying to: identify where is mistake made. Some of my web pages disappeared from Google Search results. I have found problem in Google Search Console. The problem is:
Duplicate, submitted URL not selected as canonical. Somehow Google do not separate, which of the pages is canonical - default language or translation language. I've added canonical URL's in the SEO YOAST in both pages - default language and translation language, also checked page's source codes - there is also everything right with canonical URLs. SO WHY SOME OF MY WEB PAGES ARE NOT INDEXED OF GOOGLE?

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

March 7, 2019 at 6:10 pm #3286343

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

The only element in WPML that shows any relation to indexation is the hreflang tags: https://wpml.org/documentation/support/adding-hreflang-wordpress/

I've checked a few of your pages, and it seems that in this regard WPML is outputting the correct hreflang tags.

What might cause this message that you are getting on the Google console is the following. In WPML -> Languages -> Browser language redirect, you have selected the option 'Redirect visitors based on browser language only if translations exist'. So this probably the reason that Google interprets the translations as duplicated content. And therefore you are getting the message: Duplicate, submitted URL not selected as canonical.
We have a message about it in the settings page when you select this option. Please see the attached screenshot. Please read more about it in our documentation at the following links.
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

I would like to recommend you to disable this option by choosing ' Disable browser language redirect' and wait for Google to recrawl your site and then see if the problem disappears.

Regards,
Itamar.

The topic ‘[Closed] Some of my web pages are not indexed after adding second language’ is closed to new replies.