Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by kiyokoT 3 weeks, 2 days ago.

Assigned support staff: Marcel.

Author Posts
September 17, 2020 at 2:10 am #7031729

kiyokoT

I am trying to:
show Japanese translations of product pages (some are missing for an unknown reason. Others are OK)

Link to a page where the issue can be seen:
hidden link

I expected to see:
The Japanese version of this;
hidden link

Instead, I got:
hidden link

September 17, 2020 at 1:22 pm #7037107

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thank you for contacting WPML Support.

Please try to open the affected product and press "Update". The product doesn't have a generated permalink yet and for this, you are using the internal WP URL structure. Does this create a permalink?

This could be caused because the product is still saved as "Draft" or because you need to resave the WP permalinks located at General -> Permalinks.

Please let me know.

Best Regards
Marcel

September 18, 2020 at 7:41 am #7043303

kiyokoT

Thank you, Marcel. I've done all the solutions you suggested but they did not solve the issue. But, in the course, I found all the products have already got the permalinks and the archive page (shop page) has the links to the permalinks. Also, I found the Japanese translation does not appear on the archive page either. Could you look into this further? I have attached some screenshots.

September 18, 2020 at 7:55 am #7043511

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

if you temporarily deactivate WPML, WP will create an autonomous page for this product. Can you open it if WPML is deactivated?

Please create a full backup before deactivating WPML or better try this on a staging environment. If this doesn't work, I would need to access your site for further investigation.

Best Regards
Marcel

September 21, 2020 at 2:02 pm #7060543

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I meant if the product is displayed when WPML is deactivated.

I checked your staging site and I can open the product without problems: hidden link. I opened the English product and then switched the language using the language switcher on the menu.

On your production site the server is responding with 404:

Failed to load resource: the server responded with a status of 404 ()

Please check if the product ID 2998 exists in your DB. This seems to be not an issue caused by WPML.

Best Regards
Marcel

September 22, 2020 at 1:58 am #7063771

kiyokoT

Hi Marcel, please use permalinks when you investigate the issue, because I've been using permalinks in the website from the very beggining. WPML fails to generate tanslations in permalinks with some products, which must be WPML's bug.
hidden link
Please click on the link above and try to see its Japanese translation.

September 22, 2020 at 7:25 am #7065691

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

that was not a WPML issue. You had the product saved as "Draft", so it used the internal WP permalink. I published it now over the "Publish" button.

Best Regards
Marcel

September 24, 2020 at 1:33 am #7084657

kiyokoT

Thanks Marcel but could you explain what you did clearer with screen shots? I remember the status of the product was already in "Published", so I do not know how you found it on "Draft". There are many more products that has the same issue and they are in "Published" (for instance, the one on the attached screen shot).

September 24, 2020 at 9:07 am #7088473

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

you have the English product open. I fixed before the Japanese version of the product. These products have different IDs on your database.

#1 Please hover the top-language switcher to Japanese and open the Backend of the JP product in the displayed dropdown.
#2 Here is the status "Draft" active. Here you can publish it.

Example of the JP version: hidden link

Best Regards
Marcel

September 24, 2020 at 11:48 pm #7094693

kiyokoT

Thanks, Marcel but it must be caused by WPML's bug, right? I used WPML's editor to translate the products and clicked on "finished" and "completed" but those tranlations were saved as draft by error. Could you tell the developpers to fix the bag asap? It is a waste of time for me to open each product, switch languge, and hit on publish.

September 25, 2020 at 3:21 pm #7101245

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

this issue seems to be not caused by a bug. Your WPML setting is also saved to publish directly without Drafts, so this seems to be not caused by WPML.

Did you try to publish all Drafts using the WordPress Quick Edit Mode? You can find a similar case here: https://wpml.org/forums/topic/product-saved-as-draft-appears-on-the-translated-page/#post-2994498

This will allow you to filter all Drafts and bulk publish them.

Best Regards
Marcel

September 27, 2020 at 10:53 pm #7110253

kiyokoT

Thanks, Marcel but please just pass my issue to WPML developers so that they can investigate it further. It is apparent that WPML is not working properly. I'm using WPML with SiteGround, Elementor and Astra, all of which are "standards" in wordpress development and WPML should work with them smoothly.

September 28, 2020 at 12:17 am #7110265

kiyokoT

My issue is resolved now. Thank you!