This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Bruno 3 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
May 28, 2019 at 4:32 pm #3908883

melvinP-2

Our client is using the translating services, but some pages are showing content and some are not showing content.

I have duplicated the website to a staging environment: hidden link
The English language is standard and the French language is complete (or so they say).

The problem is that this page is translated and shown: hidden link

This page is done the same, but is only showing the translated title: hidden link

Do you perhaps want a login so you could see what is wrong?

I have no experience with the translation services and it all seems okay by me.

Thank you in advance!

With kind regards,

Melvin Pulido Galan - Lemm en Ten Haaf

May 28, 2019 at 8:51 pm #3910085

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. It looks like you're using a cache plugin. Have you tried clearing the cache to see if the content is going to be displayed?

If the problem still persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 29, 2019 at 9:34 pm #3918729

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. To solve the problem in my testing environment I followed the steps below:

1. Troubleshooting
- Click on the WPML > Support > Troubleshooting. Click on these buttons under the "Clean up" section:
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information
-- Fix post type assignment for translations

2. ACF Settings
- Click on the Custom Fields > LAYOUT – Flexible blocks for about us
- Click to edit the "Flexible lay-out blocks"
-- On the "Publicatie", select "Copy"
-- On the "Content", select "Translate"
- Click on the Update button

3. Updating content
- Go to the "Quality & support" and click on the Update button
- Click to edit the translations and click on the "Save & Close" button
- Update fields correctly if necessary
- Content should now be displayed correctly

Note: in other posts, this was working even without following the steps above. This may have happened because the posts were not changed previously. After the new update of ACFML, it is necessary to make these settings and define the preference of the translation within Custom Fields.

By following these steps, please could you verify that the problem is resolved?

Thank you.

June 3, 2019 at 9:17 am #3940715

melvinP-2

Hi Bruno,

Sorry for the late reply, we had several national holidays in the Netherlands.

I have followed all your steps, but this does not resolve anything. I have also tried the simpeler pages, but they does not seem to be translated. It only shows that the translations that were at 100% are now a lot less (16% or something).

I have made the ACF options/selections fields set to 'Copy' and every content field to 'Translate'.

How is it possible that some page are translated and some not?

Is there a way to place/transfer the translation IN the pages, instead of the 'translation editor'?

Thank you in advance!

With kind regards,

Melvin Pulido Galan - Lemm en Ten Haaf

June 3, 2019 at 9:00 pm #3946157

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thanks for following the steps I posted earlier. At the moment, when I access the page that initially you reported the problem I see that the content is being displayed correctly. I'll attach an image for you to see.

What other page does the problem persist?

About the pages that are not being displayed as 100% translated, you should see which fields are not selected as translated (Translation is complete). You may need to update some field.

Thank you.

June 4, 2019 at 8:49 am #3949347

melvinP-2

Hi Bruno,

The following pages under the 'About us' are not working:

hidden link
hidden link
hidden link

Same as the 'GDPR compliance' in the footer:
hidden link

I have uploaded a screenshot of the French translation. The page seems to be at 100%.

Once this works the right way. Do we have to manually check each page (and per language) for the translations to be at 100%?

Thank you in advance!

With kind regards,

Melvin Pulido Galan - Lemm en Ten Haaf

June 6, 2019 at 12:38 am #3964635

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

In the first link, I followed the steps I posted above and saved the content in the original language.

All translations have been updated as expected. Due to the number of fields, however, the translation is not being saved because it appears that max_input_vars is too low.

Since I do not have access to your FTP, you must increase the max_input_vars limit of your PHP. You can use .user.ini, php.ini or .htaccess if your host allows. Otherwise, you should contact your host directly to make these changes.

=> create/edit the .user.ini
If your host allows, you can create or edit the .user.ini file inside the root of your site and add this line (is in the same directory as the wp-config.php file, for example):

max_input_vars = 10000

=> php.ini file

Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link

=> .htaccess file

php_value max_input_vars 10000

You can check this out in WPML > Support > Max input vars - I'll attach an image for you to see. After increasing the max_input_vars limit, follow the steps below again:


3. Updating content
- Go to the desired page on the default language and click on the Update button
- Click to edit the translations and click on the "Save & Close" button
- Update fields correctly if necessary
- Content should now be displayed correctly

After following these steps, please let me know if the content is being displayed.

Thank you.

June 6, 2019 at 8:15 am #3966957

melvinP-2

Hi Bruno,

I have changed the max_input_vars to 10000. It does not appear to place the translations. I have temporary tried it by increasing the max_input_vars. No success.

I am testing the following page: hidden link

If I want to edit the page it first opens the warning with trying to open the page in the standard editor (screenshot-1.png). I have saved and closed the translations, update the page, but no translated page.

By the way, why are the translations on that page (and many more) in the WMPL translation editor, and other pages the translations IN the standard editor?
This page is showing the content IN the standard editor: hidden link
It is very confusing if I may say so.

June 7, 2019 at 12:42 am #3972579

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. Now I can save the translation in French:

- hidden link

Initially, you just need to follow these steps:

- Open content on the original page (not translation)
- Click on the Update button (original page)
- Note that translations are now waiting for the update
- Click to edit the translation
- Translate the required fields and select the option "Translation is complete"
- When the translation is 100%, click on the "Save & Close" button

This should cause the content to display correctly in the secondary languages. Please, could you test?

Thank you.

June 7, 2019 at 9:04 am #3975005

melvinP-2

Hi Bruno,

I am sorry to inform that it still does not work. I have managed to make it work on one page (on the live website), but a second one is not working. I have tried to continue on the test website.

I have done it for the following page: hidden link

and this page: hidden link
It still shows no translations...

June 8, 2019 at 1:00 am #3979389

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I added all these pages as translated. Please, could you check if it is working properly?

Note: When you are translating the content, be sure that the "publicatie_actief" field is identical in the translation as well. I'll attach an image for you to see.

Please, could you check?

Thank you.

June 14, 2019 at 1:04 pm #4021595

melvinP-2

Hi Bruno,

I don't get it. If I follow the steps, the pages remains blank. Perhaps there are some errors on my behalf. I have included screenshot-1.png. Should these values be different?

I am trying to add the Dutch translations and I have noticed that if I update the English page, then go to the Dutch, that most of the fields are blanc (screenshot-2.png). How should I know what to enter in the translations (because they are mandatory to fill in in order to save the page). If I use the 'Copy from original' and select 'Empty fields only' (screenshot-3.png) they fill in the exact input as the original language. Is this the correct way? Anyways, the Dutch page remains blanc.

Is there a way to reset WPML and recover all translations, or are they lost?

Thank you.

June 18, 2019 at 10:22 pm #4046733

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I did not receive the screenshot you posted above. The image is not being displayed. What content cannot you translate? Maybe some other step is needed.

>>> Is there a way to reset WPML and recover all translations, or are they lost?

If you reset WPML these translations will be lost. When WPML is reset, these tables in the database will be removed and the contents will be lost.

Thank you.

June 19, 2019 at 11:23 am #4051085

melvinP-2

Hi Bruno,

I am trying to translate the Dutch version of this page:hidden link
The translations are 100% and I have checked for specifiek fields like '"publicatie_actief"'. It still does not show up when I check the Dutch page. It only shows the translated title.

What I ment with the translations I don't know how to them could be seen in attached 'screenshot-1.png' (hopefully it does upload this time).

I understand that when you reset WPML, the tablet in the database are gone. But could you still get the translations without paying double for the translating services?

Thank you in advance.

June 25, 2019 at 2:41 am #4080685

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Initially, my sincere apologies for the delay. I could not see the problem you are reporting on this page:

EN: hidden link
FR: hidden link

Both pages are displayed. I'm not sure if I understood correctly if some element is missing or some content.

About the translations, I'm sorry, but we do not keep the translations. That way, I believe you will be billed again if you want to re-translate the content of your site.

Thank you.

The topic ‘[Closed] Some pages are translated and showing, other are blanc.’ is closed to new replies.