This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Bobby 2 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 10, 2019 at 3:40 pm #3988487

ana-paulaS-2

Hello,

I'm having trouble on translating some specific points of my site hidden link

I'm using DIVI THEME and my site is in Brazilian Portuguese and English, but when I go to English Version, my header image slider photos doesn't appear. In the sidebar area, the plugins are not being translated as well, only my description. And finally, the buttons below the posts titles on the home page are not being translated too, only the title of the posts are being translated and one of the photos on the home page does not appear as well.

Could someone help me how I can solve these problems.
I thank the attention.

June 10, 2019 at 6:16 pm #3989515

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

since there a few different translation issue i would like to list them to make sure we address them and prevent any confusion.

1. header image slider photos doesn't appear
2. sidebar area, the plugins are not being translated as well
3. buttons below the posts titles on the home page are not being translated too
4. one of the photos on the home page does not appear as well.

For#1:
how are you adding the image slider ? Is it revolution slider?

For #2 :
It looks like the sidebar is linking to posts correct ? Are these custom posts ?(i see that its linking to .html )

how are you currently adding this sidebar ? Are there any translations to these posts ? at the moment i do not see any available

For #3 :

How are these buttons added ? Were you able to translate them using WPML String Translation ?
WPML->String Translation

For #4:

i assume it is the broken link one for "MEDITATION SUNG IN THE DARK AND NEW COLLABORATIONS" correct ?

if you examine the object you will notice that its missing its source please review my screenshot

Also if you go to WPML->Settings-> scroll to bottom , have you run the settings for WPML Media ? in order to make sure your images are available in all languages

July 3, 2019 at 9:53 am #4134279

ana-paulaS-2

Hello, sorry about the delay.

I’m going to answer your requests bellow.I hope that help.

how are you adding the image slider ? Is it revolution slider?

The slider is Fullwidth Slider. I think is not the revolution slider is just the regular one.I added the DIVI fullwidth block i configure to appear some highlight posts.

It looks like the sidebar is linking to posts correct ? Are these custom posts ?(i see that its linking to .html )

My sidebar have some plugins. In my opinion, not all widgets in the sidebar is linking to .html. For instance, The first part of sidebar, is about the author and is not relating to a link.

how are you currently adding this sidebar ? Are there any translations to these posts ? at the moment i do not see any available

I’m adding the sidebar via divi theme. I configure in the wordpress widget area and than I use the sidebar block in the divi theme to add the sidebar.

How are these buttons added ? Were you able to translate them using WPML String Translation ?WPML->String Translation

I tried to find the buttons in the String Translation but I didn’t find anything. I’ve already scanned the strings but I didn’t find any button to translate even some shortcode that I thought could be solve some other translation problems.

i assume it is the broken link one for "MEDITATION SUNG IN THE DARK AND NEW COLLABORATIONS" correct ?

Yes it’s correct but I’ve already run the WPML Media and I found this image on the media library, translate it but didn’t appear on the translation page. Strange. Probable I miss some step when I read the blog's articles.

I’m having a lot of problems with this plugin. Honestly the plugin is quite confuse and very complicated to solve some problems.It’s a pity but I bought it, I need to use it and I really would that this plugin solve my problem with the translation. So i need a personal or something like that help to solve these problems faster.

Could you help me or send me other options to solve these problems faster?

I really appreciate your attention with my case and I hope to solve these problems as soon as possible because is annoying read the articles in the blog and not solve my problems.Sorry for my english and my outburst.

July 4, 2019 at 6:57 am #4140561

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the detailed responses !

if possible i would like to take a closer look at the backend to better help you

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

July 4, 2019 at 8:33 am #4141241

ana-paulaS-2

Hi Bobby,

So my blog has around 23GB and will take a lot of time to make a backup and I don't have enough memory space do to that in my host plan. =(

July 5, 2019 at 8:31 am #4149061

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If you wish to proceed without taking a backup i can take a closer look without making any changes or you could possibly create a duplicator package using the duplicator plugin (excluding the media files ) and share with me the package to test locally

i have enabled the private field reply

July 8, 2019 at 9:11 pm #4165803

ana-paulaS-2

Hello Bobby, how are you?!

Did you work on the blog?! I'm waiting for your instruction to continue and finish this job.

Thanks in advance.Have a nice week.

July 9, 2019 at 7:00 am #4167847

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

1. The broken link should be fixed, it seems that you just needed to re insert the photo which resolved it

2. For the slider , please go to the specific posts that are missing the media background and review their translation to do this you can go to Posts->Edit the default language of the post->use the language switcher on the top header to stay in the page builder view and add a featured image.

they seem to be missing a featured image thus the grey background

i have resolved the first grey slider background media this way , please try the same steps for the rest and let me know your results

3. If you are adding the sidebar as widgets please go to Appearance->Widgets and select the language of the widgets , then add the widget per language

please review the following documentation

-=> https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

4. The translation of the buttons seems to take effect but then rolled back to Portuguese , if you reload the page you will notice that it goes from "Read More" to "LEIA MAIS"

deactivating WPML String Translation does not resolve this issue , therefore there is a possibility its caused by a 3rd party plugin or a cache plugin.

are you currently using any drop-in cache plugins ?

July 12, 2019 at 9:47 pm #4201691

ana-paulaS-2

Hello Bobby,

I have good news and bad news.

The good news is that I solved the problem with the images on the slider. Now is working properly with your instructions. Thank you very much.

The bad news is I'm still have problems in the widgets area and with the buttons on the home page.
I'm using drop-in cache, the WP Super Cache Plugin. Is that kind of plugin that you talking about it?

The widget area I tried your instructions but I'm not sure if i understand well but I tried this steps and didn't work. I would like to check with you what we could do to solve these problems.

If you could check again in admin area of the blog these problems I'll appreciate.

I'm going to wait your instruction. Again, thanks in advance and have a nice weekend.

July 16, 2019 at 1:48 am #4214907

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

for the widgets , if you go to Appearance->Widgets you can inspect your widgets and notice a dropdown for each widget to show on "English", "PT-BR" or "All languages"

you will need to add one for each language and that way it will allow you to translate these Titles , you can see this has been done on the Tags widget.

let me know your results with the rest of the widgets

The button should be translated now as well, there is a javascript that was being triggered switching the translation back to LEIA MAS , i was able to add it to string translation with the following wpml-config.xml code and translated it.

<wpml-config>
<admin-texts>
<key name="et_divi">
<key name="divi_integration_head"/></key>
</admin-texts>
</wpml-config>

July 17, 2019 at 4:24 am #4225757

ana-paulaS-2

Hi Bobby, are you okay ?!

Bobby, THANK YOU very much for the informations. I translated the title of the Tags plugin, the newsletter plugin and I saw that the buttons were translated as well.

However, I could not translate the tags names into English. I also noticed that my footer is not translating and the icons in my main menu disappear in the English version.

I translated many tags into english but I don't know why these tags not appear in the english version.

In the footer, I'm using the Divi Global Footer plugin. It's a Divi Theme extension plugin where I can use the same footer for all pages in the blog.I translated all the items into English but they still do not show up.

In the menu I am using a Responsive Menu Pro plugin (I paid this one)and the Safe SVG plugin to allow uploading SVG images. In the Portuguese version the images/icons appear but in the English version no. I have already translated the images in the Media tab of WPML but even they do not appear.

Would you like to know if we can solve these problems?

Again, thanks in advance and I'll waiting your instructions.

July 17, 2019 at 9:48 pm #4233617

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. For the tags it works as expected , since you are filtering by "counter" it pulls the most popular tags therefore there is a mix of both English and Portuguese tags, notice "Lifestyle", "designers", etc.

2. Please check the following documentation. It will help you to translate the Divi Global Modules. Please use the WPML Translation Editor for the easy translation of the Divi with WPML.

https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items

https://wpml.org/documentation/theme-compatibility/divi-builder/

3. As we try to keep one issue per ticket if possible please open a new thread for the svg icon issue as this will require further debugging and could possibly be a compatibility issue , please feel free to assign it to me as i am already familiar with the site.

July 23, 2019 at 9:46 pm #4268925
ana-paulaS-2

Hello Bobby, how are you ?!

About the tags, the main tags were all translated. However, they do not appear translated in the English version which I am expecting. I need them translated and not for them to appear in the Portuguese language. How can I do this?!

For the Divi Global Modules I had already read the links you had sent me and couldn't find a solution to this problem. This block is global in divi theme, but I'm using a plugin that calls "Divi Global Footer" to insert this footer on all pages. This footer is already translated, following the steps in the links you provided me and still keep appearing in Portuguese. Could you check what is going on please?

After resolving these issues I will open a new ticket to evaluate the SVG icon issues to resolve. I just need to solve these three questions to get the blog ready for the English version.

Thanks in advance for your time.

New threads created by Bobby and linked to this one are listed below:

https://wpml.org/forums/topic/split-some-parts-of-my-blog-are-not-being-translated/

July 24, 2019 at 8:15 pm #4277415

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. you are using a 3rd party plugin called Simple Tags which is not currently listed as compatible with WPML.

https://wordpress.org/plugins/simple-tags/
https://wpml.org/documentation/plugins-compatibility

if you deactivate the plugin Simple Tags and go to Appearance->Widgets->and add the stand WP widget Tag Cloud , one for EN and one for PT-BR it will pull the tags correctly and work as expected.

please test with the default tag cloud from WP and let me know your results

you can also refer the plugin's author to join our go global program to help them make their plugin multilingual ready

https://wpml.org/documentation/theme-compatibility/go-global-program/

confirm your results with me when using the standard WP Tag Cloud

2. The Divi Global Footer , I see that the footer is translated but the global footer plugin is not picking up the translation connection

are you using the Divi Footer Injector Plugin ? This plugin is also not compatible with WPML which is most likely what is causing the issue here

i have split this into its own ticket as it is a different issue please continue in the following thread

https://wpml.org/forums/topic/split-some-parts-of-my-blog-are-not-being-translated/

The topic ‘[Closed] Some parts of my blog are not being translated’ is closed to new replies.