This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by davidM-202 1 month, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
August 14, 2019 at 2:28 pm

davidM-202

I have translated my website manually (allmost completely)

However for example on the home page, when I chose another language, it does not change to the chosen language on the home page. But is does change on other pages. Please help.

August 15, 2019 at 12:02 am #4398085

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. When I try to log in to your site, the credentials do not seem to be working even if no error message is displayed.

By using these credentials the page goes back to log in again. Could you please check?

Also, please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

August 15, 2019 at 12:50 am
August 15, 2019 at 4:43 pm #4402467

davidM-202

Hi Sir, any updates?

August 15, 2019 at 10:08 pm #4403717

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for the credentials. When I access your site and switch to Spanish I see that the translation of the homepage has not yet been done. I will attach a picture for you to see.

Am I forgetting to check something? Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

August 17, 2019 at 5:45 pm #4410563

davidM-202

Hi Sir,

The problem is that the translation is not saving. See attached actions.
In action 1: I change the text.
In action 2: I save the text.
In action 3: You can see that the text is unchanged.

Try it for yourself, try to change some text, it is not changing.
Please help us

August 17, 2019 at 5:52 pm #4410565

davidM-202

See action 1 t/m 3

August 19, 2019 at 12:31 pm #4415943

davidM-202

Good morning. Any updates?

August 19, 2019 at 9:57 pm #4419353

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for the more detailed explanation. The problem was happening because the fields were marked to be "Copy" (synchronize) of the default language. Therefore the content was not changed.

I just selected the "Translate" option so that I could translate the content. I will attach a picture for you to see. Could you please check if this is working properly?

Thank you.

August 21, 2019 at 1:18 am #4426875

davidM-202

My issue is resolved now.