This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andrés 3 years, 2 months ago.

Assigned support staff: Andrés.

Author Posts
August 7, 2016 at 5:54 pm #993291

marcH-8

I am trying to:
Some of the products are not shown in the default language (English), while they are visible in German and Italian. For example, when I click on a category, it shows some of the products from one brand, but not others.
Some other categories are even empty and show only:
"No products were found matching your selection."
When I switch to the German language, the products are there!

Examples: the english shop at:
hidden link

shows 4 wine bottles below the categories.
If you go to the german version at:
hidden link
it shows all the products.
Same if I go to a category.
English category fish at:
hidden link
shows "no products were found.."
while the same category in German at:
hidden link
shows the product.
The product is there of course in English and knowing its URL I can see it:
hidden link

So, I don't think it's a plugin or theme problem, I think I set up anything wrong!! Otherwise it would not work on the other languages either.

Any idea what it could be?

thanks. marc

August 8, 2016 at 8:42 am #993734

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello again Marc 🙂

Let's try to sync your WooCommerce categories.

1. Could you please go to:
- WooCommerce > System Status > Tools
- x Recount terms.
- Then, switch your language clicking on the flag of the top bar and repeat the operation.
Do this for all your languages.

Does it help? If it does not, could you please try the following:
2.1. Backup completely your site.
2. 2. Go to:
- WPML > Support.
- Click on 'troubleshooting' link.
- Click on the 'Clear the cache in WPML' button.
- Click on the 'Remove ghost entries from the translation tables' button.
- Click on the 'Set language information' button.

I'll wait for your comments.

Best regards,
Andrés

The topic ‘[Closed] Some products are not shown in default language’ is closed to new replies.