Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Vincenzo 5 years, 5 months ago.

Assigned support staff: Vincenzo.

Author Posts
March 31, 2015 at 1:28 pm #591379

ireneL-3

I am trying to: get rid of this ALERT

I visited this URL: http://wpml.org/forums/topic/wpml-config-xml-2/ and https://wpml.org/forums/topic/wpml-configxml/

I expected to see:

Instead, I got:

April 1, 2015 at 8:29 am #591938

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello and thank you for contacting WPML support.

Please BACKUP your database before doing these steps.

To remove that warning you need to reset the icl_sitepress_settings value in wp_options table.

1) Rename icl_sitepress_settings to icl_sitepress_settings_backup in wp_options table, so we have a backup of original WPML & WCML settings
2) Then go to wpml -> languages, finish the language installations steps.

The above steps will add new values for icl_sitepress_settings in wp_options, thus updating the WCML settings.

You can do this using the Adminer plugin.

Please let me know if you need help with this.

April 1, 2015 at 9:15 am #591988

ireneL-3

Hi Vincenzo,

thanks for your answer and explanation. What will happen if I don't correct that error?
should I do it?

I'm asking because I got a bit afraid reading this case: https://wpml.org/forums/topic/wpml-config-xml-2/

Also I've seen that I have an update available of the woocommerce multilingual (version 3.5.5), should the problem be solved with this?

sorry to bother you but I'm really worry to loose all the job as I have short time to finish it..

thanks and regards

April 1, 2015 at 9:40 am #592010

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I understand your worries and no, you don't bother me at all 🙂

The problem in that case is that during WPML setup, the client probably choose a different default language from before.

This can be avoided by writing down all the settings in WPML -> Languages and can be easily solved by restoring the database backup that you did before trying this.

Anyway, before trying this, please try updating WooCommerce Multilingual.

As usual, please make a database backup before updating.

Please let me know if it works.

April 30, 2015 at 11:40 am #609601

ireneL-3

I'm trying to finish install a double copy of my web online, hope to have it this weekend and I'll try to do what you suggest, I'll come back to you in the next days.

thanks

May 1, 2015 at 9:16 am #610159

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok I will wait for your confirmation.

The topic ‘[Closed] Some settings from the WooCommerce Multilingual wpml-config.xml file have been o’ is closed to new replies.