Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Lauren 4 days, 23 hours ago.

Assigned support staff: Lauren.

Author Posts
November 5, 2019 at 5:44 pm #4892331

davidA-29

I am trying to:

Display default language (English) content for Woo elements like the 'Add to cart' button.

Link to a page where the issue can be seen:
hidden link

I expected to see:
'Add to cart' as the string for the add to cart button

Instead, I got:
"Προσθήκη στο καλάθι" - Greek

Greek is not an activated language - only English and Arabic are selected. Greek is, however, the language for another site on this network.

This issue has happened since I upgraded to WPML 4.3.2 and it ran the scans to create the mo files as part of the update process.

I've searched in the database for this Greek string, and it is not found in the _icl_ tables for this site.

I've also done a grep -R in wp-content/languages/wpml/123 and not found this string.

Other sites on the network don't seem to have been affected by this issue.

I have cleared Redis and WP Rocket but that has not solved the issue.

As this site is part of a large network, I don't want to provide a Duplicator package, but I can provide a DB dump of the site's tables, and a zip file of the wp-content/languages/wpml/123 folder.

November 5, 2019 at 6:30 pm #4892861

Amit
Supporter

Hi, Amit here, I am the WPML support manager. This issue actually sounds to me like a possible glitch, Προσθήκη στο καλάθι is the Greek translation for "add to cart".

So I think it's coming from the native MO file. Maybe we wrongly switch the locale (even temporarily).

It'd be great if we can take you on that offer of sharing the DB table relative to the site, it might be useful to have the language folder as well.

I would also like to please ask you to update to WPML 4.3.3, now if the issue is still there after the update, please share with us the DB dump and other information in the private comment I am activating for you.

Thanks!

November 6, 2019 at 9:14 pm #4901815

davidA-29

I noticed the languages/wpml/missing/woocommerce-en_US.mo file contains incorrect translations. Renaming that seems to have worked in the specific example given (Add to cart).

November 7, 2019 at 8:12 pm #4909905

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi David, my name is Lauren and I"ll be handling your ticket. Just to be sure I understand correctly, when you rename the missing/woocommerce-en_US.mo, this resolves the issue with the incorrect language displaying. Is this correct?

November 7, 2019 at 10:04 pm #4910225

davidA-29

Yes, that resolved the issue for now. If you see the screenshot from that .mo file, you can see it's got Greek translations for English (USA), that's why Greek translations started showing up for English sites.

So the question is why did WPML create that file with incorrect translations.

I say it's resolved for now because I have no idea if WPML is going to create that file again with another set of incorrect translations.

November 8, 2019 at 1:55 pm #4913895

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Great, thanks for clarifying. I'm going to escalate this to our developers so that we can prevent this from happening in the future. Would it be possible to get a snapshot of your site so that I can share it with them? If so, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

November 21, 2019 at 12:10 am #4984805

davidA-29

Hello. I've been looking into this in more detail and had a few more reports from site owners of incorrect languages being shown. This network uses Redis to cache option data, and flushing the Redis cache fixes the issue.

I've marked this as still needing assistance because I would like to know what cache groups I need to exclude from Redis to prevent this happening again.

November 22, 2019 at 2:47 pm #4999227

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for the additional information. I'm checking with our developers to see which groups can be excluded. For these other sites where it is happening, are the .mo files in the /missing/ folder still where you have found the incorrect translations?

December 2, 2019 at 3:48 pm #5055363

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

We recently released a new update. Please go to Plugins -> Add New -> Commercial and click Check for Updates. Then, install and activate the latest version. Does this resolve the issue with the incorrect language strings?