Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Dražen Duvnjak 7 months, 2 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
October 12, 2020 at 12:23 pm

Kristof

Some strings are not translated

October 12, 2020 at 1:51 pm
October 14, 2020 at 5:18 pm #7229593

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. I tried to access the provided website to give a detailed look at the reported issue but it seems the website is offline, can you review it please? Thank you for your continued patience and understanding, have a nice day.

October 15, 2020 at 8:24 am #7233825

Kristof

Due to disk space limitations, we were unable to keep the staging. I could give you access to the live site, but you won't be able to edit stuff there.

October 16, 2020 at 1:29 am #7240577

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case, I would appreciate if you could generate a duplicator package of your website, so I can investigate your issue at my localhost host, without having to interfer on your live website. For that, please, consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

October 16, 2020 at 6:32 am
October 16, 2020 at 6:17 pm #7245857

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look at your 'Resources View (offset 1)' content and couldn't notice anything wrong, however, when saved the 'Read More...' label is being displayed in the dutch language from String Translation settings, something I am checking with my colleagues in order to get some more details.

For now, I would recommend you to give a try at this resource: https://toolset.com/documentation/legacy-features/translating-legacy-workflows/wpml-string-shortcode/ so you can adapt your view to display this label wrapped in the wpml string shortcode.

Please, let me know if it helps, have a nice day.

October 19, 2020 at 8:14 am #7255421

Kristof

I have replaced the Toolset Read More shortcode link with plain html and a WPML translatable string.
3 remarks about:
1/ when we just use [wpv-post-read-more] without custom label, the existing translations are not visible
2/ we suddenly see this very strange string show up in our list.
3/ the Search string from [wpv-filter-submit] still does not translate.

Screenshot_11.jpg
Screenshot_10.jpg
October 20, 2020 at 12:47 pm #7265929

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It is weird I checked the issue again at my localhost and everything appears translated properly as you can confirm in the attached screenshot. Can you please, confirm if you have any cached view from your WordPress Dashboard > Toolset > Views settings? If so, please, click the button 'Clean cache' from the list of views and let me know if you see the strings translated properly. Have a nice day.

customer_screen_155.png
October 20, 2020 at 3:24 pm #7267861

Kristof

Where did you find that layout? That is an old layout. It should look like hidden link

Except for the search in the right corner, no Views are being cached.

I have now reverted the change for the highlighted post (the large one to the left of the most popular items) so it uses the [wpv-post-read-more] shortcode.
As you can see from my screenshot, every "read more" label has been translated into Dutch and French, yet no translation is loaded in the frontend.

Screenshot_13.jpg
October 22, 2020 at 1:50 pm #7285463

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi there,

Marcos is off today, so I am taking care of this ticket, hope that is OK. 🙂

1) As I understand from the latest reply when only using wpml-string shortcode as Marcos suggested, then it is translating correctly and showing fine on the front? Make sure context is not set to wpv-views.

Can you please confirm?

2) When you use [wpv-post-read-more] it works fine, but when you use [wpv-post-read-more label="Read more"] it doesnt show correct translation of label?

I would say that is exceeded, and the correct way of doing so if you want to translate it is adding it next: [wpv-post-read-more label="[wpml-string context=”my-context”]Read more[/wpml-string]"]

As suggested here:
- https://toolset.com/forums/topic/translate-wpv-post-previous-link-linkprevious-post-with-wpml/

Please let me know if this suggested fix satisfactorily for you.

Kind regards,
Drazen

October 29, 2020 at 9:31 am #7332721

Kristof

1)

[wpml-string context="my-strings" name="read-more-btn-text"]Read More[/wpml-string]

Yes, this is translating correctly and showing fine on the front.

2a)

[wpv-post-read-more]

Does not show the translations, we also don't see an entry in the String Translations for this. But as this belongs to the default WPV shortcodes, we expect is to be the preferred way.

2b)

[wpv-post-read-more label="Read more."]

This one shows up as Domain 'page-builder-shortcode-strings-17938' but translations entered in String Translation are ignored and only English string shows up in all languages.

2c)

[wpv-post-read-more label="[wpml-string context="my-strings" name="read-more-btn-text"]Read More[/wpml-string]"]

This does not work, we have tried before and there is an issue with the consecutive double quotes. See screenshot.

Conclusion: the [wpv-post-read-more] shortcode is totally useless when needing translations. The only thing we got working is

<a class="elementor-post__read-more" href="[wpv-post-url]" style="margin-bottom:15px">[wpml-string context="my-strings" name="read-more-btn-text"]Read More[/wpml-string]</a>
Screenshot_1.jpg
October 29, 2020 at 12:55 pm #7335501

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback.

Ok, so you want to use [wpv-post-read-more] and are expecting it to work.

I have tested on a clean sandbox and it seems to be working fine, please check the video:
- hidden link

That tells us the issue is only happening only on your site and it is not a general WPML bug. I will need to check your site to see what goes wrong and try to fix it.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site/staging site wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

You can safely add your information to these fields.

If you can not provide wp-admin access, please provide a Duplicator copy, filter media files to keep the size smaller. The one you provide before has link expired.

Kind regards,
Drazen

The topic ‘[Closed] Some strings are not translated’ is closed to new replies.