Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 21 replies, has 2 voices.

Last updated by Bigul 3 weeks, 5 days ago.

Assigned support staff: Bigul.

Author Posts
April 15, 2021 at 8:48 am #8542321

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the FTP credentials. I have downloaded the latest version of Jet Engine plugins and doing detailed testing on my local server now. Also will consult our second-tier team for an expert opinion on this. Please wait.

--
Thanks!

Bigul

April 16, 2021 at 8:49 am #8552609

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I had a few rounds of testing on my local copy and the issue is reproducible only when the Yoast plugin is active. So one request. Please make sure you are getting the expected results when Yoast is inactive or not.

--
Thanks!

Bigul

April 16, 2021 at 11:36 am #8554587

Thilo von Osterhausen

Hey Bigul. We can sure try but we use jetengine + yoast + wpml on another site without any issues. Does this resolve the API status error in your backend WPML settings also?

April 16, 2021 at 11:48 am #8554677

Thilo von Osterhausen

Issue still perisists.

What i did:

- deactivated both yoast and yoast multilingual
- checked error log for most recent error.
- went to woocart builder list and redelivered the translation for cart page
- waited for 2 mins and then refreshed
- hour glass still shown
- checked error logs and showed new communication errors

Screenshot 2021-04-16 at 12.45.04.png
Screenshot 2021-04-16 at 12.45.30.png
Screenshot 2021-04-16 at 12.44.57.png
April 16, 2021 at 11:49 am #8554747

Thilo von Osterhausen

just also seen this error pop up at the top.
Warning: array_key_exists() expects parameter 2 to be array, null given in /home/clients/a21b1449c058deb9cd0c5996d5c3bc75/sites/kanoa-surfboards.com/wp-content/plugins/wpml-translation-management/classes/ATE/class-wpml-tm-ate-jobs.php on line 51 not usre if related.

April 16, 2021 at 2:27 pm #8556459

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. On my local copy, the REST API is showing as enabled in WPML>>Support>>WordPress section. Please check the attached image for more details. So it requires further debugging.

Now all the JetWooBuilder Templates posts are showing as translated. Therefore I have switched back to Classical Translation Editor and update translation?

Which hosting provider you are currently using for hidden link? Hope the other site(with JetEngine+Yoast+WPML) is also hosted on the same server.

Also, please let me know the exact steps to reproduce the following warning. Unable to replicate it exactly.

Warning: array_key_exists() expects parameter 2 to be array, null given in

--
Thanks!

Bigul

2021-04-16_19-53-31.png
2021-04-16_19-51-55.png
April 19, 2021 at 12:11 pm #8572049

Thilo von Osterhausen

Hey Bigul. Lets just get back to the core issue here.

Issue:

ATE sometimes fails to send translations off and get hour glass.
Sometimes can be resolved by deleting and resending

Reproduction: Most commonly occurs on JetWooBuilder Templates

Steps to reproduce.

1. Turn on ATE
2. Resubmit Any jetwoobuilder template after editing
3. Hour glass displatys and translation doesnt go through
4. Visit error log and see "
The translation job could not be applied. WPML JOB 0 (always zero) ....ATE JOB (numbers)

Temporary solution
Turn off ATE and Use classic. Not long term solution because we need ATE features.

Other issues that maybe related. False negative on REST API not available.

To your comments above we are hosted on Informaniak servers but when we first raised this issue we were hosted on Siteground. The issue persisted across migration from dev to prod so i would suggest is not host related.

Please can you escalate this issue further as its been over a week now. Thanks bigul

April 19, 2021 at 3:46 pm #8574255

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I am consulting about this with our team for an expert opinion. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

April 20, 2021 at 11:55 am #8581277

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We are still working on this bug. One more question. While migrating the site, WPML Translation Management will ask for the following option. So which one you have selected after migrating to a new server.

a) This is a new URL

b) This is a copy of the site

Also, it will be great if you can consult with the hosting provider about the REST API settings. Because in our local servers the site copy is showing it as enabled.

--
Thanks!

Bigul

The topic ‘[Closed] Some translations are stuck processing’ is closed to new replies.