This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by gilesH-3 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 16, 2019 at 1:24 pm

gilesH-3

I am trying to: Set translations to live

Link to a page where the issue can be seen: hidden link and hidden link
I expected to see: All blocks on the front page in spanish / some content on the certification page

Instead, I got: Some blocks in spanish, some in english. On some pages nothing shows up at all.

Also - we think some setting may have been affected by an update to the plugin?

To see the site you may need to get past htpassword login : newlpi / Mvx1?3h7

July 17, 2019 at 3:00 pm
July 17, 2019 at 3:01 pm #4231501

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

July 17, 2019 at 3:19 pm #4231671

gilesH-3

Thanks - I will ask our developer support to get this set up for you.

July 18, 2019 at 12:55 am #4234069

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, let me know when you are ready. Thanks!

July 18, 2019 at 12:57 pm #4238769

gilesH-3

Hi - migration is complete
hidden link

July 19, 2019 at 8:23 pm #4248099

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provide details. I am jumping here to let you know I am working in your issue, due the complexity of your custom fields setup I would need some extra hours to fully debug it. Thank you for your continued patience and understanding, have a nice day.

July 23, 2019 at 10:59 am #4265287

gilesH-3

Hello - do you have an update for this?

July 24, 2019 at 2:18 pm #4275501

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for you patience while waiting for a solution. I took a detailed look in your website settings using the migrated copy and could make the pages with missing content to work following these steps:

1 - In your WordPress Dashboard > Pages I cliked to edit the 'Certifications' page and finished the spanish translation, I noticed this page had a 'translation in progress' status, it is needed to finish all your pages translations before seeing it in the website frontend.

See: https://wpml.org/documentation/translating-your-contents/

2 - After the page translation was finished I changed to the secondary language (spanish in your case) in order to edit the translated page using the native WordPress page/post editor and just clicked the 'update' button. This step is needed in order to refresh the database tables values and this way make it to appear properly in the website frontend.

You can see the results at: hidden link.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

3 - Another step you should take is to double review your translation preferences for your custom fields content. For that you should proceed this way:

3.1 - In your WordPress Dashboard > Custom Fields > Fields Groups click to edit the 'Content' fields group and review the individual settings of each field and set it properly as 'translate', 'copy', 'copy once' etc. For example you can make the images fields as 'copy' or 'copy once' and the image titles as 'translate'.

See:

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Note: Only fields set as 'translate' will be shown in the translation editor.

4 - The same fix can be applied for any page with missing content and your homepage as well as the core issue here are incomplete translations (translation in progress) and your custom fields with wrong settings for its translation preferences.

Please, let me know if you need any additional assistance. Have a nice day.

July 25, 2019 at 1:50 pm #4283723

gilesH-3

We tried this and it seems something is still not working.

I spent 20 minutes on changing everything in Custom Fields > Content to “translatable” and now when I want to go to “Pages” it shows me this:

(image)

I clicked “Apply” at the bottom, but still it says my changes will be lost when I leave…

July 26, 2019 at 9:44 pm #4291953

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the waiting here? In wich page are you seeing this dialog box? It seems you are trying to access other WordPress admin section without saving your changes. Once you click the Apply button you also should click the 'Update' button for your page/post or custom fields settings, otherwise you will loose your changes and this is what your message wants say. Please, let me know if you need any additional assistance and instructions, have a nice day.

August 1, 2019 at 8:06 am #4319533

gilesH-3

My issue is resolved now. Thank you!