This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Itamar 1 year ago.

Assigned support staff: Itamar.

Author Posts
September 25, 2018 at 9:09 am

seand-4

I am trying to: I have translated the site into German and everything is working great except some images for products are not displaying against some products in woocommerce, fine for the English site but not dispalying on the German site.

Link to a page where the issue can be seen:

English Page
hidden link
hidden link
hidden link

German Page
hidden link
hidden link
hidden link

I expected to see: I assume the images should copy over to the German pages - most other products have worked correctly - It just all of the Audi category and one in the BMW section.

Instead, I got: Images not showing correctly in Audi \ BMW

September 26, 2018 at 8:32 am #2766456

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the issue on your site. I've checked this example hidden link from the links that you have sent me. And I can see that the image this category term is also showing in German Media Library. Please see the attached screenshot.
So it supposes to also show for the German category term. Therefore, I suspect that this is a cache issue. You are using the W3 Total Cache plugin for cache on your site.
Can you please clear all the cache from your site and see if it helps to solve the issue?

Thanks,
Itamar.

September 26, 2018 at 8:51 am #2766490

seand-4

Hi Itamar,

I wish it was that easy. The issue was there prior to us adding that plugin on - I have purged all caches though and the issue is still there. I have just disabled w3 cache plugin until we can get this resolved.

Its strange - the Audi \ BMW were the first set of products we translated - the rest we did at a later date - the new ones are fine and the old ones are not.

Any help appreciated.

September 26, 2018 at 9:34 am #2766649

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

Can you please try the following?
1. Go to WooCommerce -> WooCommerce Multilingual -> Categories (tab) and scroll all the way to the bottom. There will see the 'Synchronize Product categories assignment in content' button. Press it and wait for the process to finish.
2. Now switch to the Hierarchy Synchronization tab and press the 'Synchronize Product categories assignment in content' button and wait for the process to end.

Is it solving the issue?

Regards,
Itamar.

September 26, 2018 at 10:04 am #2766775

seand-4

Hi Itamar,

I have followed those steps - and still have the issues.

Any further help appreciated.

Thanks...

September 26, 2018 at 11:59 am #2767061

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks for following on this as well.

Please also try the following.
1. Take a backup of the DB of your site.
2. Go to WooCommerce -> WooCommerce Multilingual -> Settings (tab).
3. Press the 'Troubleshooting' link at the right bottom corner of this screen.
4. On the troubleshooting screen, check the Sync products "gallery images" option and then press the start button and wait for the process to finish.
5. Do the same also for the Sync products categories (display type, thumbnail) option.
Please see the attached screenshot.
Does this help to solve the issue?

Regards,
Itamar.

September 26, 2018 at 12:28 pm #2767204

seand-4

Hi Itamar,

Thank you for the continued support.

I have done that to both options and I am still having the same problem.

Anything else?

Thanks..

September 26, 2018 at 2:00 pm #2767579

seand-4

Hi Itamar,

I have deleted the featured image for this one :

hidden link

Actually deleted the image out of the media library altogether and re uploaded and it seems to be ok on that one - so I guess i need to do it for the rest?

September 26, 2018 at 2:40 pm #2767708

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Although I thought it was not needed to suggest this before because I could see that the image (of the one post that I've checked) is duplicated to the other language, I'll also suggest now the following. Go to WPML -> Settings -> Media Translation and make sure that the following options are checked.
- Translate existing media in all languages
- Duplicate existing media for translated content
- Duplicate the featured images for translated content
And press the 'Start' button.

If this does not help to solve the issue, then I can see that for Audi and BMW you have a total of 12 cars. So removing the featured image and uploading it again shouldn't a lot of work. So, yes, please proceed with this action to solve the issue.

Thanks,
Itamar.

September 27, 2018 at 1:26 pm #2770699

seand-4

Hi Itamar,

Its actually 40 images by the looks of it - looking at it in more detial - the latest thing you sent us to try didn't work. Anything else we could try - some how those images are not associating themselves properly to the default product.

Another issue which might be related.

This is the English Product

hidden link

This is the german product :

hidden link

They have a link to a fitting guide. The English version of the fitting guide has been updated with a new pdf - but the German product has not picked up that change? How can we make that link update to the new pdf?

New pdf :

hidden link

German pdf (old one) :

hidden link

thanks.

September 27, 2018 at 7:29 pm #2771639

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I didn't understand the first part of your last reply.
Do you prefer that I'll continue to debug this issue rather than upload the images again (a solution that worked)?
I think that we are still looking here on cache issue. I say it because when I inspect the image in this post, for example, hidden link, I can see that the link is to a file in the uploads folder that was uploaded in /2017/04/ Please see the attached screenshot 2017-04-img.jpg. But in the Media Library, I find this file only in /2018/09/; Please see the attached screenshot 2018-09-img.jpg.
The W3TC plugin is a very complex cache plugin with a lot of options.
Are you sure that you have cleaned the cache properly?
Maybe you also have a cache on the server level?
Please check that as well.
If you still want me to debug this issue, then I'll need to do it with your site's copy on my local server. For this, I've installed and activated the Duplicator Pro plugin on your site. Please deactivate the cache plugin and security plugin and create a package for me. Doing it while cache and security plugins are active usually fails. Instruction for the creating a package with the DUplicator can be seen here hidden link
Let me know once it is done so I can download the package.

PDF issue
To upload a different PDF file for the German language, please do the following.
1. Go to WPML -> Media Translation.
2. Search for the PDF.
3. Press the pencil icon.
4. And upload a different PDF file.
Please see the attached screenshot de-pdf.jpg.
Is it working for you?

Regards,
Itamar.

The topic ‘[Closed] Some Woocommerce products images not displaying correctly.’ is closed to new replies.