This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 4 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
June 2, 2019 at 11:18 pm

irfan

Hello,

When click on configure button in WPML Multilingual CMS option in plugin list I am getting error

Sorry, you are not allowed to access this page. Error

same error is appearing when I goto appearence --> menu and language switcher.

I have did all checks likes disabling all plugins except wpml and switch to default theme but issue is still there

Debug option is also not showing in my wpml

hidden link

I am using backupbuddy and have full backup.

Please advise.

Regards

Irfan

June 3, 2019 at 3:21 am #3939043

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

To fix this, I suggest you to run the following snippet:

function wpmlsupp_1706_reset_wpml_capabilities() {
    if ( function_exists( 'icl_enable_capabilities' ) ) {
        icl_enable_capabilities();
    }
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );

Just add the above code in your theme's functions.php file (between the <?php and ?> tags) or at the very bottom of Appearance > Editor > functions.php and visit once the front-page.
Then you can remove this snippet.

Now try to configure WPML.
You should be able to configure it.

Please let me know if this fixes the issue.

Thank you!
Riffaz.

The topic ‘[Closed] Sorry, you are not allowed to access this page. Error’ is closed to new replies.