Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Itamar 5 days, 22 hours ago.

Assigned support staff: Itamar.

Author Posts
November 11, 2019 at 9:17 pm #4928225

federicoM-24

Tell us what you are trying to do?
Hello, I translated some of my website from Italian to English and Russian and other languages were translated from English by another translator. The problem now is that after making some changes to the home page I can only translate it from Italian to all languages, this has some how caused it to loose all translations in the translation editor. Maybe if I'm able to set the source language back to English I can recover the translations, is there another way to recover them?

What is the link to your site?
hidden link

November 12, 2019 at 6:28 pm #4934167

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Things are not quite clear to me. Currently, I can see that English is the default language fo your site.
Was this changed in the past?
Was the site's default language not English?

The following documentation might help in understanding how to do things correctly.
https://wpml.org/documentation/translating-your-contents/how-wpml-keeps-track-of-your-translations/
https://wpml.org/documentation/translating-your-contents/translation-editor-options/

If you need more information from me, could you please share your Debug information with me?
You can read a detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

November 17, 2019 at 9:26 am #4959963

federicoM-24

English is the default language for our site now, before it was Italian, the issue existed also then.

Debug information attached

November 17, 2019 at 8:01 pm #4961035

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, and thanks for attaching the debug information.

By looking at the debug info that you have attached, I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Please, also clear all the cache from your site and deactivate any cache plugin or method that you are using on your site.

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

November 27, 2019 at 4:44 pm #5031277

federicoM-24

I've raised the WP Memory Limit to 1024, I still have the problem of source languages being quite random. I want to make the source language for all my pages english, at the moment some are italian and some are english and sometimes they seem to change randomly when I make a change to a page

November 28, 2019 at 3:40 pm #5037743

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Changing the source language of a page is not possible with WPML. When I write "changing the source language," I mean the following. If the page was created in English, you could not later change it to be a page in Italian. You can only translate the page. You might be able to change the source language of a page in the DB. But this might just cause other problems, and I wouldn't recommend doing that.

You wrote: "I want to make the source language for all my pages english, at the moment some are italian and some are english and sometimes they seem to change randomly when I make a change to a page"

The source language of the page shouldn't change when you update the page.
Can you please let me have access to your site and explain to me where and how I can see this problem?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

December 1, 2019 at 7:42 pm #5050205

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, and thanks for the access details.

I've checked things on your site. Here are some of my conclusions.

1. If you change the default language of the site, problems like you are experiencing might occur. We have a clear warning about in WPML -> Languages when you want to change the default language. Please see the attached screenshot warning.jpg

2. The above might even get complicated if you have translated your site with external Translation Services. Which you say you did. But when I go to WPML -> Translation Management -> Translation Services (tab), I don't see any selected Translation Service.
Can you please tell me which Translation Service did you use to translate your site?
How did you send the Translation Service the translations?

3. Your site uses the WP Rocket cache plugin and maybe other cache methods.
Please clear all the cache from your site and deactivate any cache plugin and see if the issue persists.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site, you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

4. I can see that the Elementor page builder is active on your site. But it seems that the pages were not built with Elementor. When I edit the Concerti page, for example, I don't see any Elementor element. Please see the attached screenshot elementor-ele.jpg
Can you please tell me how you have built the pages of your site?

Thanks,
Itamar.

December 2, 2019 at 1:24 pm #5053597

federicoM-24

As explained earlier in the conversation default language was changed in an attempt to make the source language English, the problems with changing source language was already there, changing the default language hasn't added any extra problems that I've noticed and hasn't solve ant either.
Translations were made by an external translation agency, we used the included translation manager to do this assuming this was a safe way (screenshot attached) since it's a built in feature of the plugin.
Freeing the cache or disabling wp-rocket doesn't solve the issue.
All pages were made with Elementor including the concerti page (as you can see in the screenshot).

What I need is a way to make the default language English for all translations so I can make Elementor changes only the English pages and other languages will update easily using the WPML advanced translation editor, that is the reason why I purchased the plugin in the first place.

December 3, 2019 at 11:17 am #5059909

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

OK, I think that I get the issue now.

In this case, please proceed with the steps that Carlos, my colleague gave you on the other ticket that you opened with this issue here.
https://wpml.org/forums/topic/source-language-of-some-pages-have-changes-and-this-is-messing-up-my-website/#post-5037267

Carlos wrote:

There are two options to change the default language of a page:
- If the page is not translated, then you can edit it -> Go to Languages block in the right column and select the desired language for the page.
- If the page is already translated, you can:
-- Delete the translation and apply the steps above.
-- Re-create the page and assign the desired language.

I need to mention that if the page that you want to change from another language to English was created with Elementor, you might lose the Elements and would need to add everything back. Which means that you would need to re-create the page with Elementor.

Please let me know if this information is helpful to you.

Thanks,
Itamar.

December 3, 2019 at 6:55 pm #5063799

federicoM-24

It's not exactly an easy solution, basically I have to make the whole website again! But if it's the only way I guess that's what needs to be done

December 4, 2019 at 12:56 pm #5068591

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Yes, I can understand that it might be a lot of work for you. But still, it might be that you will not lose the Elementor elements. This needs to be tested. And maybe you will be able to reimport the translations from the Translation Service into the English page. But this needs to be tested as well. I would recommend you to test things on a copy of your site and not on the live site.

If you want, we can create a test server for you were you can migrate your site and check things there. This way, we will also be able to debug the problem of the source language that is randomly being changed. Until now, I could not see where this issue is happening on your site.

Please note that if you created a page in English, for example, and then translated it into the other languages with WPML's Translation Editor, you should keep editing the other languages with the Translation Editor. If you edit the other languages with the WordPress editor, this might result in the problem that you describe. The following documentation explains how to do it correctly.
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please let me know if you want us to create a test server for you.

Regards,
Itamar.