We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Bobby 3 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 11, 2019 at 7:48 pm #4192917

paulM-51

I am trying to: When we click on Spanish language button, the page correctly changes to Spanish language. But when we click on a "more details" button (in Spanish, the "mas detalles" button), it takes us to the English language page instead of the Spanish version of the page.

Link to a page where the issue can be seen: hidden link (the page won't be able to be seen though - the site's on maintenance mode while we finish building and testing it)

I expected to see: If we're on a Spanish language page, clicking a button on that page should take us to a different page on the website. That new page we're taken to should already be in the Spanish language because we're already in Spanish language mode.

Instead, I got: Instead, clicking the button takes us to the right page but not the right language for that page. It takes us to the English version of the page instead. Then we have to click the Spanish language link at the top of the page in order to get the page to switch to the Spanish translation. The button should take us to the right Spanish page without having to re-click on the language translation choice link at the top of the page.

We're able to set up translations for each page, including the wording on the buttons, but we don't see a way to change the links for each button so that it will connect to the right Spanish version of the same page instead of going to the English version of the page (which then means having to click the language translation link at the top of the page to get it to switch). It's creating an extra step for our possible site visitors that shouldn't be happening. What do we need to do to fix this?

July 11, 2019 at 8:55 pm #4193079

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

how are you adding these buttons and their links , are you using a page builder module ? if yes please let me know which page builder and module(the button) is it?

a possible quick solution i can see here is to go to Pages=>Edit default language page=> use the top header language switcher to access the secondary language and remain in the page builder view this way(ignore the warning message)

now edit the button link and add the correct one and update the page

let me know your results please

July 11, 2019 at 9:46 pm #4193211

paulM-51

We're using Astra theme with Elementor page builder. The modules involved are Image, Heading and Button modules. Each needs to be updated with links to the Spanish page instead of the English version of the page.

But I thought that once you go into the Elementor page builder via the translator, you can't go back to the translation editor to adjust the page anymore? So I'm hesitant to follow your quick solution if it means we can't edit the page via the WPML translation editor because we've altered the Spanish pages via Elementor.

What should I do?

Thanks!

July 12, 2019 at 5:28 pm #4200753

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

If possible i believe it would be best if you could provide me with a duplicator package to further test this issue either locally or on our cloudways servers, this way i can verify a solution without affecting your live site's current workflow

i have enabled the private field reply to provide me with the duplicator package

you can use the following plugin
=> https://wordpress.org/plugins/duplicator/

or if you wish you can provide me with the backend access details and i can create the duplicator package and update you when done

July 12, 2019 at 11:40 pm #4201825

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the access details

Go to pages -> Private Oahu Island Tours page-> click on "pencil" icon to edit the translation and scroll down

you will find the field for the following URL link in the Button: Link URL field
hidden link

and i can see that it has simply been copied over rather than translated in the Translation Editor which is why it takes you to the English page.

i added the correct URL to the translation field and re saved , now the first button works as expected

please review the rest and let me know your results

July 15, 2019 at 8:56 pm #4214613

paulM-51

Hi, Bobby - thanks very much for your help! We see where to change the translation for the URL on the button and the image, but is there also a place to change the URL for the headings? The headings are links to each tour as well.

Thanks again for the assistance.

July 16, 2019 at 2:21 am #4215153

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

unfortunately i am not able to access the site anymore as the credentials are not working to take a second look regarding the header link but what are your results if you examine the translation page , do you see a field for the header URL ?

July 16, 2019 at 4:06 am #4215923

paulM-51

I see a field for the header itself (the text of the header) but not a field for applying a URL to the header (even though we do have one on the English language page, and the Spanish page takes you to the English language page when you click on the header).

What should we do?

July 16, 2019 at 4:41 am #4216133

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

If possible please renew the above credentials so i could take a closer look at this

There is a possibility the URL might be within the WPML-.String Translation screen

July 16, 2019 at 11:09 pm #4224381

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Please try editing this string manually and let me know your results

go to pages->edit Spanish page and then edit with elementor->select the header and change the link then update

let me know your results please

July 22, 2019 at 9:40 pm #4261487

paulM-51

I'm not seeing a place to edit with elementor after you go to Pages and click the icon to edit the Spanish version of the Oahu page. It just shows all the WPML fields to change, and there isn't one for the header link. Plus, I thought there was no way to go back and edit via the Pages translation icon / WPML plugin once you've edited the individual Spanish page via elementor? If I do that, will I not be able to edit this page via WPML plugin translation options? Thanks again for your help!

July 22, 2019 at 10:37 pm #4261623

paulM-51

We tested it updating via Elementor, but we need to be able to update it via the Translation editor of your plugin because our client won't know how to update via elementor. They only update via the translation plugin. Is there a way to add a URL translation field for the headers on the Oahu page like there are URL translation fields for the buttons and images? Thanks again!

July 23, 2019 at 7:05 pm #4268683

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Please find a list of the supported modules of Elementor with WPML

https://wpml.org/documentation/plugins-compatibility/elementor/#List-of-the-translatable-Elementor-Elements

at the moment it seems that the Header URL link is not being picked up , i have updated our developers regarding this and will update you once i have some news

July 26, 2019 at 11:02 pm #4291995

paulM-51

Thanks, Bobby! We appreciate all your help.

July 29, 2019 at 7:42 pm #4303265

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

we have a fix for this issue that is going to be included in the latest release of WPML

at the moment if possible please provide me with your FTP access details so i can add the change manually

also please update your current WPML version as well