Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by georgK-14 1 month, 2 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
February 22, 2021 at 5:55 pm #8147751

georgK-14

We finished our translation for our website and now the spanish translation is loading 10x slower than the english version?

I went through all the articles and still no success. What I am doing wrong?

February 24, 2021 at 8:33 am #8160445

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello!

Welcome to WPML Support.

I'll do my best to help you solve this issue.

1) I have checked your site and it looks fine for me. Can you please share if you still have an issue and how can I see it?

2) Does the same issue happen when you are using only WPML plugins and ACF plugins on the WP default theme?

Please let me know.

Thanks and kind regards,
Drazen

February 24, 2021 at 1:15 pm #8163591

georgK-14

Yes issue is the same. We also have around 112 strings in our theme and only 5 or so show up for translation.

We use now WPRocket to speed things up - but still sometimes the spanish version needs more than 10 seconds to load and the english only 0,4 (same page, same images)

Also the spanish pages have something strange in the title - which we can't explain.

We worked on this project 4 months and beside COVID the translation seems to be the most difficult one.

What can we do - to make this work?

Screen Shot 2021-02-24 12 45 26 AM.jpg
Screen Shot 2021-02-23 11 20 18 AM.jpg
February 24, 2021 at 3:23 pm #8164819

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

Please note we limit 1 issue per 1 ticket, I will share some initial documentation that you should check and follow, but if you still have the other 2 mentioned issues, please open a new ticket for each and we will be glad to help out.

- https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/
- https://wpml.org/documentation/related-projects/using-wordpress-seo-with-wpml/

As for your original issue, it seems you are seeing cached pages on EN (0.4s) but on Spanish on the first load, you are seeing cached versions, after you reload load time is fast, correct?

It could be there is some other cache involved, like server page cache.

Can you please follow the next steps and let me know the results:

Please make a backup before proceeding.

1) Install Query monitor plugin (https://wordpress.org/plugins/query-monitor/)

2) Check the ES vs EN page and load time and number of queries in the top bar, when WP Rocket cache cleared and plugin disabled.

3) Disable all other plugins and leave active only WPML plugins and WP Rocket, switch to WP default theme. Check again.

4) Disable all other plugins and leave active only WPML plugins.

Compare load time and the number of queries between the EN page and ES. This will tell us if WP Rocket is caching the EN page or something else is, and what is the difference between languages.

Please let me know how it goes and the results for each step.

Don't hesitate to ask if you find any problem along the way or have doubts or questions about the steps mentioned above, I'll do my best to help you in the best way possible.

Regards,
Drazen

February 25, 2021 at 2:08 pm #8173131

georgK-14

We have so many issues. Fields and titles are randomly translated, all strings disappear - I ask support via the chat function - hope they will solve this soon - it is a disaster.

February 26, 2021 at 7:01 am #8178539

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I am so sorry for any troubles you are having, be sure our support will do the best to help you out.

If you still have an original issue from this ticket and would like us to check further, please follow my last reply.

Thanks and kind regards,
Drazen

February 26, 2021 at 10:17 am #8179543

georgK-14

Hi
I have no idea how to use this query-monitor. I just need this problem to be fixed. Nothing is really working and I get fatal error messages in the media library.

I went through all the forum this last two days and no success.

February 26, 2021 at 10:28 am #8179561

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback.

I understand, please note each issue will be taken care of separately in the correct ticket, my colleagues will do their best. We require some patience and collaboration from you, in order to provide proper help.

Please let's not mix issues and keep the conversation clear, so it is easy to follow.

Your issue with this ticket is: Spanish translation is loading 10x slower than English.

Let start this over, please share a video of the issue happening, how can I see the issues, and how are you measuring load time.

You can use some free tools for recording video, like LOOM (loom.com).

Thanks and kind regards,
Drazen

March 4, 2021 at 3:35 pm #8229697

georgK-14

My issue is resolved now. Thank you!