This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by akivaL 1 week, 3 days ago.

Assigned support staff: Radu.

Author Posts
September 12, 2019 at 4:34 pm

akivaL

I am trying to: Translate the Neighborhood page and after typing in changes they aren't displayed.

Link to a page where the issue can be seen: hidden link

I expected to see: Changes in Spanish

Instead, I got: Only the duplicated content.

September 13, 2019 at 9:17 am #4566913

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Akiva,

Can you tell me if you made any change to the page lately, please? I'm asking this because i was trying to edit the page in English but I got the message that somebody else is editing it. I just want to make sure that I'm not checking it out while you are still working on it (and maybe on the translation too).

Thanks,
Radu

September 13, 2019 at 2:31 pm #4569447

akivaL

No changes are being made please go ahead.

September 16, 2019 at 2:20 pm #4581239

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Akiva,

Can you tell me if this issue about these custom fields that are not translating is only happening on the Neighborhood page, please? Also, can you try to delete the translation and create it again, please? I checked all the settings, both on the plugin and on the custom fields. Everything looks fine and I cannot understand what's going on but this little change might do the trick.

Thanks,
Radu

September 16, 2019 at 2:25 pm #4581279

akivaL

Hello Radu!

I've deleted and recreated the translation 10 times! Nothing has worked.

Please read my original post, this only happens on the Neighborhood page not any others. Thanks!

September 20, 2019 at 10:10 am #4611311

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Akiva,

I looked into this a bit more but I couldn't find why is this happening only on this page. I checked all the settings once more but I still couldn't see anything wrong with them.

In this case, is could you create a duplicator package by following the steps presented here https://wpml.org/faq/provide-supporters-copy-site/ and give me a message back once the package is generated, please? I'll just log into the dashboard area and download the archive (without having to upload it to Google Drive, for example). This way I'll be able to create a copy of your website and pass it to the 2nd tier supporters if it needs some more investigations.

Thanks,
Radu

September 23, 2019 at 4:21 am #4620155

akivaL

Duplicator won't work. The WordPress installs are running Multisite. Here's what Duplicator says: Multisite: Unsupported
Duplicator does not support WordPress multisite migrations. We recommend using Duplicator Pro which currently supports full multisite migrations and subsite to standalone site migrations.

While it is not recommended you can still continue with the build of this package. Please note that at install time additional manual custom configurations will need to be made to finalize this multisite migration. [upgrade to pro]

I'm trying to find an alternative way to isolate just this website.

September 25, 2019 at 7:40 am #4636361

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Akiva,

Can you tell me if you made any changes to the Neighborhood page, please? I'm asking this because I had another look at it and the content is no longer displayed (see the attached screenshot).

Also, have you tried to delete the original English page too, create it again, and then translate it to Spanish? I was thinking that maybe there's something wrong with the original page since this is happening only in this case, and all the other pages work fine.

In the meantime, I'll look for some options to migrate only a specific site from your multi-site, if this page re-creation doesn't get things fixed.

Thanks,
Radu

September 25, 2019 at 1:08 pm #4638995

akivaL

Yes I did make a ton of changes but nothing is working and as you can see now the page isn't displaying.

Good thing I have a backup of the site at hidden link that I created before I started this process. I've created the same user name and password for you there. If you can maybe try and translate the page there I can overwrite what's on Somerstonenc.com

Maybe I did the translation steps incorrectly and caused all this with the Neighborhood page?

Thanks!

October 2, 2019 at 11:53 am #4679943

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Akiva,

Thank you for creating me an account on the staging website too. As I can see, I have administrator right but I cannot access the plugins page. I just wanted to check the version of the plugins that you're using.

Also, I had a look at the Neighborhood page on the staging website and I could see that there's no translation for it. Can you create the Spanish translation (you can have a look at this article to see how to configure the custom field for translations: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/) and give me a message back once you made the translation, please?

I wanted to do this change by myself but I wasn't able to see if the ACF Multilanguage is installed and active. Please try this one and I'll have a look at this as soon as you reply me back.

Thanks,
Radu

October 7, 2019 at 8:59 pm #4710771

akivaL

My issue is resolved now. This is an issue with a custom page template. It had a hardcoded post_id value in it. Thank you!