This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

How can I have different ACF repeater fields on the translated page?

Solution:

Dealing with repeater fields can be complicated, especially when you want to achieve different results on the translated page as needed in your case. The issue was that not all the fields were set to 'Translate' but you couldn't see those fields. They are systems fields. So you need to do the following.

A. On the editing screen of the translated page scroll down to the Multilingual Content Setup section.

B. Press the 'Show System Fields' link and wait for the system fields to load.

C. Set all the ACF fields that are set to 'Don't translate' to 'Translate'.

D. Press the "Apply' button.

E. Update the page.

F. Add the new row and update the pages again.

This topic contains 14 replies, has 2 voices.

Last updated by juneW 4 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
May 8, 2019 at 2:16 pm #3767627

juneW

Hi Itamar,

I should've mentioned in an earlier post that I did turn on the Debug for both the live and staging sites April 25th.

On the staging website, I reverted the theme to twenty seventeen but doing this results in nothing working at all. There is no toggle or way to switch between languages. I can't see half the content.

I turned the Theme back on but with the following plugins activated because without them you can't see the site at all:

- Advanced Custom Fields
- Advanced Custom Fields Multilingual
- Advanced Custom Fields PRO

All of these actions have been done on the staging website here: hidden link

Summary of problems that continue to exist:

**********************

HOME PAGE

Multilingual settings had switched to 'Do Not Translate' ( have updated to 'Make translateable'

On the french version, all translated content is missing. All content was somehow removed.

Here is a backup I took from April 18th. Content has gone missing since this date!
hidden link

Is there anyway to get my translated text back without having to copy it back over from the backup?

**********************

DISCONNECTED PAGES:

Pages have disconnected from their translations. These translations were setup properly by clicking + from the original translation and were NOT created separately. Despite this, they have become disconnected

hidden link

takes me to hidden link

Instead of hidden link which was the original translation of this page.

From the Wayback Machine, you can see that the pages were connected as of Nov 18th, 2018.

hidden link

(click on the french toggle and it will show you the link was hidden link)

There are several pages under Committees and Locals that have become disonnected

**********************

LOCALS > NON PUBLIC FUNDS - showing French version of Go Local rather than English

Again, from the back up from April 18th, 2019: hidden link

See how the buttons all say 'Go Local'.

See live website: hidden link

Somehow these buttons have all switched over to French? On the April 18th version, you can see the buttons were still not working properly, in particular for Bagotville which was showing two.

**********************

I don't really get how the pastebin.com is suppose to work so I've pasted the debug.log for the live website (hidden link) here: hidden link

Please advise. Priority is to address the missing home page content and re-connect pages with proper translations.

Thanks,
Tanya

May 8, 2019 at 2:32 pm #3767743

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

In our forum, we try to keep one issue per ticket.
Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster. Therefore, I've split the other ticket and created a new ticket with this issue. In this ticket, we'll continue with the homepages issue that is missing the ACF fields translations.

Currently, when I go to edit the homepage of your site, I see that almost all of the fields are set to 'Don't translate'. Please see the attached screenshot field-set-not-trans.jpg.
You wrote: "Multilingual settings had switched to 'Do Not Translate' ( have updated to 'Make translateable'"
Do you refer to this section?
Has it switched again after that you had set it to 'Translate'?

You ask: "Is there anyway to get my translated text back without having to copy it back over from the backup?"
The option, in this case, would be to set it to 'Translate' and check if the translations are kept.

Can you please tell me what happens in this case?

Thanks,
Itamar.

May 8, 2019 at 3:22 pm #3768415

juneW

Hi Itamar,
I understand what you are saying in terms of separated issues, but having observed the translation problems with the site, I believe there may be a single source of the problems that are causing both the missing content & disconnected pages. That is why I posted them into one ticket.

I made the changes requested on staging: hidden link
The debug info submitted as well as screenshots below are from this website rather than working directly on live.

To answer your questions:

**************

Itamar: You wrote: "Multilingual settings had switched to 'Do Not Translate' ( have updated to 'Make translateable'"
Do you refer to this section?

Tanya: Yes, however The home page is just one example - this same issue is happening on other pages throughout the website resulting in lost content.

**************

Has it switched again after that you had set it to 'Translate'?

Since April 18th, yes, it has switched on it's own to Do Not Translate. I changed it back to 'Make translatable, but the French content from the page is missing.

As mentioned in my previous comment you can see the April 18th, 2019 backup of the Home page here:

hidden link
hidden link

**************

Itamar: You ask: "Is there anyway to get my translated text back without having to copy it back over from the backup?"
The option, in this case, would be to set it to 'Translate' and check if the translations are kept.

Can you please tell me what happens in this case?

Tanya: Updating the Systems settings to Translate does not bring back the content. I tested this out on the staging website: hidden link

The content boxes are showing on the French Edit page, but no content is showing, eng or fre.

**************

From what I can tell, we started to notice missing french content sometime after November 18th, 2019. The site had not had problem up until that point and no plugins etc. had been added.

This post is in reference to translation strings, but could their be a connection where recent WPML changes have caused further issues with ACF?

Tanya

May 10, 2019 at 2:46 pm #3785737

juneW

Hi Itamar,

Here is another video demonstrating where when attempting to add the same content back to the french page, it does not stick. Adding the content works on the staging but not on the live website.

I've:

- Made sure the Multilingual settings are all the same
- Ensured plugins are the same

Still, I get a different result.

Here is a video: hidden link

hidden link
hidden link

You have access to both these websites. Where do we go from here? I feel like we have exhausted the potential of plugin conflicts and incorrect settings. How do I get to a resolution? These custom fields were all working up until a couple of months ago when we started to know odd behavior (missing content).

Tanya

May 11, 2019 at 4:45 am #3789517

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Tanya and sorry for the late response here.

Thank you for your answers. But I can not see the video. I get: "This video is unavailable." when I go to the video link.
Can you please check that and make the video available?

I can see that on your site WordPress is not updated to its latest version. Also, the Advanced Custom Fields Multilingual add-on is not updated to its latest version. This latest version was released yesterday. It is important that WordPress will be updated as well. I'm not sure if I've mentioned that before here or on the original ticket, but it is important that keep WordPress updated as well. There had been some changes also on the ACF plugin to match the latest versions of WordPress (since version 5.0). So, for now, I would like to ask you to update WordPress and Advanced Custom Fields Multilingual and see if the issue persists.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Can you try that?

If still, things are not working as expected, then I need a copy of your site, please. We have an easy way to migrate your site to our test server. In the next private message that I'll add in a couple of minutes, I'll share with you all the details on how to migrate your site to our test server. It is important that you will migrate the live site from here hidden link where we can see the issue.

Thanks,
Itamar.

May 14, 2019 at 3:14 am #3802999

juneW

Hi Itamar,
I understand what you are saying about ensuring plugins and WordPress are up-to-date but in this case, in order to troubleshoot, wouldn't you say it's important to look at apples to apples. I didn't update plugins because I wanted to make sure one site's plugin and WP version were the same as the other.

I will look at your instructions for copying the live site first thing tomorrow and also look at the YouTube settings. I think that is the video you are referring to? I had posted a link in my first comment as well.

Thx.
Tanya

May 14, 2019 at 3:32 am #3803133

juneW

Itamar - please try to view the 2nd video link (youtube) again now. It is now public. I would like to remove it once you've viewed.

Thx. Tanya

May 14, 2019 at 12:06 pm #3806585

juneW

Hi Itamar, I have started the migration this morning.

Thx.
Tanya

May 14, 2019 at 6:40 pm #3809993

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Tanya.

Thanks, I can see the video now.
Tanya, you are not working correctly with WPML and ACF. You are editing the French page which is the translation of the English page (default language), and this is why things are not working for you. You should always start with the default language page when ACF fields are involved and only then translate the page and its fields to the second language. And it would be better and more convenient for you if you would work with WPML's Translation Editor and not with the WordPress editor. Please carefully review our documentation about how to work with WPML and the ACF plugin at the following link.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/
The relevant part to the issue that we talking about is here.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-acf-fields

I hope that this information will make you understand how to work better with WPML and ACF. Please let me know.

Regards,
Itamar.

May 15, 2019 at 4:13 pm #3818661

juneW

Itamar, I feel like we are going in circles here.

From your answer, I think you are assuming that the home page is a new page? Did you have a look at the home page? The small boxes being added are NEW content for the page. Steps 1-3 outlined https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-acf-fields were completed when the page was originally published.

*********

Your comment: You should always start with the default language page when ACF fields are involved and only then translate the page and its fields to the second language.

*********

Can you please look at the cloned website at hidden link (that you requested I setup) create a video of how to add those new small boxes to the french page so I can see exactly what is not being completed properly.

This is the quickest way to identify what steps I am not taking properly.

Thank-you.
Tanya

Note many french and English pages have slightly different content from one another. I believe that the translation editor was confusing in these circumstances as I did have it turned on at one point.

May 15, 2019 at 4:14 pm #3818665

juneW

Also please note that we were able to add the Featured Panels ACF fields below without issue.

May 16, 2019 at 9:00 pm #3829391

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Tanya.

After a long debugging process, I was able to identify what was preventing you from adding more fields on the French translation of the homepage. Dealing with repeater fields can be complicated, especially when you want to achieve different results on the translated page as needed in your case. The issue was that not all the fields were set to 'Translate' but you couldn't see those fields. They are systems fields. So you need to do the following.
A. On the editing screen of the translated page scroll down to the Multilingual Content Setup section.
B. Press the 'Show System Fields' link and wait for the system fields to load.
C. Set all the ACF fields that are set to 'Don't translate' to 'Translate'.
D. Press the "Apply' button.
E. Update the page.
F. Add the new row and update the pages again.
Please see the video that I've recorded while performing this.
You can see it here hidden link

Please let me know if this helping to achieve what you need.

Best Regards,
Itamar.

May 21, 2019 at 1:18 am #3850749

juneW

Hi Itamar, I will take a look your notes and report back here once I have tried it out.

Thx.
Tanya

May 22, 2019 at 1:09 pm #3865995

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks, Tanya.

I'll wait for your reply.

Regards,
Itamar.

May 28, 2019 at 10:08 am #3905219

juneW

My issue is resolved now. Thank you!