This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by Bigul 4 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 12, 2019 at 2:18 pm #4005133

hlaingM

Hi,

The goal is for the ads and the effect of the 4 add-ons to appear in both languages
regardless of the language the ad-poster uses to post the ad from the front-end. The admin is NOT supposed to get involved or assist from the back-end.

I tested with 2 different ads
(1) My yellow cat missing (posted in English)
(2) My yellow cat missing (posted in 2nd language)

The effects of the 4 addons are not generated when the ad is posted in the 2nd language. I am attaching the issues when the ad is posted in the 2nd language.

I edited the private credentials (username) on WPML so you can have a look at the issues with the account shown.

Thanks.

June 12, 2019 at 2:48 pm #4005459

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

The credentials are not changed the previous thread. So I am enabling the private option for the next reply. Please share me the credentials of the user having the issue.

Also one more doubt, the featured ad posts are not listing in *Featured Listings* section of Homepage, am I right? Please check the attached image.

--
Thanks!

Bigul

June 13, 2019 at 11:29 am #4012341

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details and login information. As part of our debugging procedures, I have tried to reproduce the issue on our Sandbox test site. But it works for me. Please check the attached images and the following URLs.

hidden link

hidden link

Therefore I have a request, can you please share a screencast for a better understanding of the issue. Sorry, on your live site I am a bit confused because of the Burmese Characters. Especially during this selection - hidden link

--
Thanks!

Bigul

June 13, 2019 at 4:31 pm #4015627

hlaingM

Hi,

The characters are appearing properly because your browser does not have Zawgyi-one font installed.

hidden link

Please see the image attached for zawgyi-one installation instruction.

Regarding your question on translations of contents on the ad submission page/step 1, please see the image attached.

Please see the link below to see the effects of each addon. I recommended trying with "Highlight my Ad" and " Top Search Results List".
hidden link

I think you missed my objective. "The goal is for the ads and the effect of the 4 add-ons to appear in both languages regardless of the language the ad-poster uses to post the ad from the front-end. The admin is NOT supposed to get involved or assist from the back-end."

In summary, I do not see the effects of the add-on generated, meeting my object.
Thanks.

June 14, 2019 at 12:29 pm #4021301

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I have created two Burmese ad posts and it is only listing as *Latest Listings* in the secondary language. But its listing in *Featured Listings* on English. Please check the attached images.

It looks like you are auto duplicating the Ad posts, am I right?

This may be happening because the Order(transaction) post is only created in English while posting in from secondary language. So please set *Translatable - use translation if available or fallback to default language* as translation preference for Order(transaction) in WPML>>Settings>>Post Types Translation and check you are getting the expected result or not.

--
Thanks!

Bigul

June 14, 2019 at 2:43 pm #4022267

hlaingM

Hi,

So I just did what you said "set *Translatable - use translation if available or fallback to default language* as translation preference for Order(transaction) in WPML>>Settings>>Post Types Translation"

No, I don't get the effect of addon when the ad is posted in the 2nd language. For the sake of simplicity, let's focus on the "Highlight my Ad" addon. As you can see in the image, the ad posted in the 2nd language is NOT reflecting the effect of the addon "highlight my Ad".

Please let me know if you see the issue. Thank you.

June 17, 2019 at 8:02 am #4032907

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I can reproduce the issue on your site and my local copy(tried with a fresh Duplicator copy). But it was working for me last week. So have you made any changes recently in the Addon settings?

Please check the attached images for more details.

--
Thanks!

Bigul

June 17, 2019 at 8:46 am #4033363

hlaingM

Hi,

Thank you for an update. I am not aware of making changes to the settings. Perhaps, you did not clear the cache.

Just try with the the highlight add-on for the sake of simplicity to see if the plugin works with WPML. From what I have observed, it has not been working with the WPML.

The plugin developer is willing to work with the WPML team to make his plugin to work with the WPML. So please identify the issues and help to get it to work.

Thank you.

June 18, 2019 at 9:58 am #4042355

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. It looks like a compatibility issue. As I mentioned before the plugin is not officially tested by the WPML Compatibility team yet.

So as part of our escalation procedures, I have tried to reproduce the issue in minimal setup(with your duplicator copy on my local server) and in a fresh installation(Sandbox test site). The issue is existing on my local copy after the initial debugging steps.

But I am not able to reproduce the issue exactly in a fresh installation. The Highlight Ad is not highlighting the Ads in English and Burmese. I used the same CSS class of your live site. Maybe I missed some settings. So can you please check in the fresh installation that the issue is reproducible or not. Please check the following login URL.

hidden link

hidden link

--
Thanks!

Bigul

June 18, 2019 at 10:17 am #4042651

hlaingM

Hi,

I just looked into the sandbox, where correct slug for "highlight" was NOT typed in CSS area. On the same page, the correct slug (which can change based on the title text you choose) is given to you.

I just posted 2 ads (one posted in English, the other in 2nd language) Now, you can see the issues when the 2nd language switch is ON.

June 18, 2019 at 6:14 pm #4045771

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have reproduced the issue and escalated the ticket to our compatibility team for further debugging. Please check the attached image.

We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

June 24, 2019 at 8:27 am #4075425

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the highlight ads are working fine in the Parent theme and also it works fine while posting the ad from the backend. Please check the Sandbox test site - hidden link

This issue is happening because of the customized code of your child theme. Now while creating Ad post from frontend with the child theme, the Ad post is duplicated in both languages. Which is wrong. Please check the attached images for more details.

We have limitations here because of the custom code which is out of the scope of our support.
So as a workaround you can use *wpml_admin_make_post_duplicates* API - https://wpml.org/wpml-hook/wpml_admin_make_post_duplicates/ or you can contact one of the WPML contractors - https://wpml.org/contractors/

Thank you for your understanding.

--
Thanks!

Bigul

June 24, 2019 at 9:27 am #4075985

hlaingM

Hi,

I need clarifications on the following you said:
"This issue is happening because of the customized code of your child theme. Now while creating Ad post from frontend with the child theme, the Ad post is duplicated in both languages. Which is wrong. Please check the attached images for more details."

(1) Which customized code of my child theme? what specific file in the child theme? for customized codes for featured listing?

(2)'Now while creating Ad post from frontend with the child theme, the Ad post is duplicated in both languages. Which is wrong."

I opened a ticket previously and I was told that ads submitted in the 2nd language can be copied to default English using custom codes....My freelance coder added codes so that the ads posted in the 2nd language can be copied to English.

Thanks.

June 24, 2019 at 3:11 pm #4078227

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. While posting an ad from the frontend you are duplicating the post automatically to the other language. But the issue is instead of setting one language as original and other as duplicate, now both are set as Duplicate. For example, if we are creating an ad post from Burmese frontend the Post language should be Burmese and English post should be a duplicate. Instead of it, both are showing as duplicate posts now. Please check the following images for more details.

hidden link -Original post

hidden link - Duplicate post

So you have to change the code in the functions.php of the child theme. Specially in *wpml_duplicate_on_publish* function.

--
Thanks!

Bigul

June 24, 2019 at 3:26 pm #4078327

hlaingM

Hi,
I am not understanding what you meant.
"For example, if we are creating an ad post from Burmese frontend the Post language should be Burmese and English post should be a duplicate. Instead of it, both are showing as duplicate posts now."

I saw the links you showed. But, I just don't understand how to interpret/make of it. How do you know both posts are duplicates when I post an ad using Burmese?

Thanks