This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

On the WPBakery Blog Element the posts fallback option is not working for all available posts.

Solution:

In this case the option was selected to filter the posts for the WPBAkety BLog element by post category. In order to show post sin default language on translated pages the original post categories need to be added and the blogs will show up on all pages in original language, in case a translation is not existing yet.

Relevant Documentation:

https://wpml.org/documentation/theme-compatibility/creating-multilingual-sites-using-the7-theme-and-wpml/

This topic contains 8 replies, has 2 voices.

Last updated by rohanK 2 months, 4 weeks ago.

Assigned support staff: Andreas W..

Author Posts
July 9, 2019 at 8:55 pm #4174353

rohanK

And I forgot the last point:
- the blog posts that are not shown in english if there are not translated

Thanks again for your help,

Kind regards

July 9, 2019 at 9:25 pm #4174437

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

While testing the fallback issue and trying to translate the page Employers/Switzerland/ I received another error on your site:

Fatal error: Uncaught Exception: Template file is missing for `ff` shortcode. Make sure you have `wp-content/themes/your_theme/vc_templates/ff.php` file in your theme folder. in /home/approachwr/www/wp-content/plugins/js_composer/include/classes/shortcodes/core/class-wpbakeryshortcode.php:270
Stack trace:
#0 /home/approachwr/www/wp-content/plugins/js_composer/include/classes/shortcodes/core/class-wpbakeryshortcode.php(243): WPBakeryShortCode->loadTemplate(Array, '')
#1 /home/approachwr/www/wp-content/plugins/js_composer/include/classes/shortcodes/core/class-wpbakeryshortcode.php(360): WPBakeryShortCode->content(Array, '')
#2 /home/approachwr/www/wp-content/plugins/js_composer/include/helpers/helpers.php(1316): WPBakeryShortCode->output(Array, '')
#3 /home/approachwr/www/wp-includes/shortcodes.php(325): vc_do_shortcode(Array, '', 'ff')
#4 [internal function]: do_shortcode_tag(Array)
#5 /home/approachwr/www/wp-includes/shortcodes.php(199): preg_replace_callback('/\\[(\\[?)(ff)(?!...', 'do_shortcode_ta...', '[ff id="1"]')
#6 in /home/approachwr/www/wp-content/plugins/js_composer/include/classes/shortcodes/core/class-wpbakeryshortcode.php on line 270

The error is realted to a template file missing inside of the theme folde rin order to use WPBakey. I would advise you to consult the theme support about this issue. Anyhow, I do not think this issue is linked to the problem with the WPML fallback option.

In fact, as mentioned earlier the page Employers/Switzerland is not yet translated into German, which for it is correct that not any post is showing up for the German page.

The French page is showing two English posts, and one French posts that were already translated. The fallback seems to work but the page builder is only visualizing two of the English posts. The Blog Carousell Widget gathers the blogs from their categories. You will need to add all categories in order for the blogs to be able to show up.

I tried to added the English category "Work abroad", then updated the page but I received again the above mentioned error. Please reach out to theme support in order to solve it.

Let me know if you got any questions.

Kind regards
Andreas

July 10, 2019 at 8:55 am #4177405

rohanK

Hello Andrea,

You are confusing the pages. First of all the the page Employers/Switzerland is translated in English, French and German, but there are no blog posts on it so it is normal that you don't see them as even in English, there are not, however, the testimonials are showing into the right translation for instance. Here are the 3 pages:
- hidden link
- hidden link
- hidden link

The issue you see is related to the Flow Flow plug in and WP bakery in general, not the blog post or WPML. We are in contact with Flow Flow developers.

To understand the problem with the fall back, you need to go on candidates pages that have blog posts displayed. Now if we take the example of Candidate/Switzerland: hidden link

You need to check the german translation to see the error as in the french translation, the blog posts you can see are in fact french translation (I just copy paste the content in english waiting to have the french content) so that's why they are displayed because in fact there are french blog posts. But all the other posts are not shown because there are not translated (not related to the categories options).

Waiting for your news,

Kind regards

July 10, 2019 at 2:24 pm #4181361

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I am sorry for picking up the wrong example but it behaves the same way for all pages.

The page Switzerland / Candidates is translated into French and includes some of the English posts.

It includes:

- How to write a winning CV?
- How do I prepare for a job interview?
- 6 common CV mistakes to avoid (which is already translated into French)

All those posts have the post category "CV Advise".

The missing Category "Work abbroad" has been included on the page editor, but in order to show those blogs the page will need to be translated again. On my test, the translation fails with the Classic Translation Editor.

As mentioned in my last email, there is an error which is very likely caused by the fact that there was an error message regarding WPBakery, which explains that a file is missing inside of the theme folder.

Please contact the Theme Support for assistance on this matter.

Further, the page Switzerland / Candidates is not yet translated into German. Please open the translation editor, and you will see that the translation status is 0%.
This is why the blogs are not showing up yet. Complete the translation to 100% and you should be able to see English posts.

Now, to get back to the error, it mentiones that the theme is missing a vc_template called ff.php. The theme support team should be able to assist you with this task. Once the file is added you should be able to update and translate content as usual.

Let me know if it worked out.

Kind regards
Andreas

July 11, 2019 at 11:14 am #4189057

rohanK

Hello Andreas,

Oh okay I got the issue for the call back now. But the problem is that we had to adapt the design to be able to add the text in German / French and keep the look & feel good. So we added the translation directly on the page translated in the CMS. We DID NOT go on the english page and used "WPML's Translation Editor". Is there a way to make understand WPML that the page is 100% translated and then have the blog posts showing even in english?

Regarding the error with WP bakery, as explained previously, it is an error with Flow Flow plug in that is missing compatibly with Flow-Flow, they are working on it, I have contacted them as soon as you told me a few weeks ago ;). But the error is just that we receive this message error when we save a page with a flow flow feed but the changes made are saved on the page and the plug in Flow Flow is working anyway.

Looking forward to hearing from you,

Kind regards

July 11, 2019 at 3:09 pm #4191445

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

The workaround here would be to deactivate the WPML Translation Editor for single pages. Go to the page and check the right sidebar for language options. Here you should see a switch option in order to activate or deactivate the WPML Translation Editor.

Once you activate this option a poup will ask you if you wish to applz the setting to the current page or all pages. I would advise you to select current page only here.

Now, you will have to make your translations manually on the WordPress backend by changing the admin site language in the top admin bar.

Let me know if this solved the issue. In case you still experience issues udpating the page make sure to try to disable the Flow Flow plugin or even other plugins, in case the issue still persists. Once the page got updated the posts should show up.

Kind regards
Andreas

July 17, 2019 at 2:51 am #4225387

rohanK

Hello Andreas,

Sorry for the late reply but I had various other projects to manage.

Anyway, I tried your solution on the candidate / france page : hidden link

I deactivated WPML Translation Editor, the page was already set to french, verified that the blog post category "work-abroad" in the blog carousel below the title "Travailler en France: laissez-nous vous guider" but still, we cannot see any blog posts on the front end.

Is there something I am doing wrong?

Thanks a lot for your help

July 17, 2019 at 8:51 pm #4233443

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I visited the page hidden link

The Blog Carousel did not include the post category "work abroad".

Further, I translated this category at WPML -> Taxonomy Translation.

The fallback option for posts is now working for this site. In order to show posts the Blog Carousel please inlcude all affected post categories inside the pabe builder element´s options.

Kind regards
Andreas

July 18, 2019 at 4:25 am #4234935

rohanK

You are so fantastic Andreas and I a very dumb on this one 😉 Thank you very very very very much for all you amazing support!