This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The link on the menu is redirecting to the main language

Solution: In this case, it's because the client is using a custom link for a product. This way WPML can not translate it automatically.

It was fixed using this steps: - Go to Appearance> Options - Click on "Screen Options" (on the right top) - Select Products - Add the Product to the menu and rename it to "Booking" - Delete the custom link - Save

This topic contains 2 replies, has 2 voices.

Last updated by garyW-15 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
October 9, 2018 at 4:08 pm #2800991

garyW-15

now the problem is only on booking page, when I click on booking (main menu) go to eng version

October 9, 2018 at 4:21 pm #2801043

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

This is because you are using a custom link for the "Bookings". This way WPML can not translate it automatically.

Please try the following:
- Go to Appearance> Options
- Click on "Screen Options" (on the right top)
- Select Products
- Add the Product to the menu and rename it to "Booking"
- Delete the custom link
- Save

Please let me know if it worked for you.

Regards,
Diego

October 9, 2018 at 7:30 pm #2801808

garyW-15

My issue is resolved now. Thank you!