This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by servaaso 3 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 25, 2019 at 12:07 pm #4084369

servaaso

Hi Bigul,

OK, thanks for giving the head up.

Kindly note, I just noticed that when I add a new product I cannot add the (featured) product image (gallery images I can add no problem..), until I turn off the "Woocomerce Multilingual plugin". With that plugin turnoff I can add.
Not sure if it is related to the problem at hand, but thought it might help you during debugging.

Best regards,
S

June 25, 2019 at 12:13 pm #4084409

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Image is not attaching to the Product Image field when WooCommerce Multilingual plugin is active, am I right?

I can reproduce the issue on your Duplicator copy. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

June 26, 2019 at 1:55 am #4087675

servaaso

Hi Bigul,

Thanks for the split! Yes that is exactly what happens, do note that gallery images CAN be added.

S.

June 26, 2019 at 8:05 am #4090287

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It is working as expected in my local copy when *Stripe Payment Gateway for WooCommerce(Basic)* plugin is inactive. Please check the attached image.

So to make sure please try the following steps and let me know you are getting the expected result or not.

1) Please deactivate *Stripe Payment Gateway for WooCommerce(Basic)* plugin for a moment
2) Activate WooCommerce Multilingual
3) Create a test Product with Product Image

--
Thanks!

Bigul

June 27, 2019 at 1:19 pm #4100321

servaaso

HI Bigul,

After following the steps I can indeed confirm that I am getting the expected results when the Stripe plugin is de-activated.

Thanks,
S

June 28, 2019 at 9:22 am #4105987

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But I am not able to reproduce the issue exactly in a fresh installation. It is working fine when WooCommerce Multilingual and Stripe Payment Gateway for WooCommerce(Basic) plugin is active together.

Please visit the following URL and check the issue is reproducible or not.

hidden link

--
Thanks!

Bigul

June 30, 2019 at 9:15 am #4113811

servaaso

HI Bigul,

On the fresh install the issue is not existing... so there must be something with the local install.

Do note that, on the local install, when the stripe plugin is activated but multilingual is deactivated, the problem also goes away.. so thats why its not certain that is either the stripe or the multilingual plugin
On another note, there is a blank image as the first image in the image selection window (see screenshot)

Any suggestions?

Thanks,
S

July 1, 2019 at 7:13 am #4115957

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I will forward the details to our second tier team for the expert opinion. But now not able to login to the site with the credentials you shared. So enabling the private option for the next reply. Please share the login credentials.

--
Thanks!

Bigul

July 2, 2019 at 5:17 am #4124077

servaaso

On advice of WPML support we switched to another Stripe payment plugin.

My issue is resolved now. Thank you!