If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Carlos Rojas 1 year, 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 30, 2018 at 1:45 pm #2594287

krisdaH

I switched to advanced editor. The home page translated but now when I try the Accommodations page. I get the following error whenever I click the translation edit link for that page.

Catchable fatal error: Argument 1 passed to wpml_tm_save_data() must be of the type array, object given, called in /home/thaicondos/public_html/web/wp-content/plugins/wpml-translation-management/classes/ATE/class-wpml-tm-ate-jobs.php on line 112 and defined in /home/thaicondos/public_html/web/wp-content/plugins/wpml-translation-management/inc/wpml-private-actions.php on line 18

July 30, 2018 at 3:01 pm #2594646

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please try the following steps after a full site backup and make sure the issue is existing or not.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

3) Go to WPML>>Support page

4) Click on Troubleshooting link (blue link in the middle of the page)

5) In Troubleshooting page, please click on the following options of *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

6) Then try to translate the *Accommodations* page

--
Thanks!

Bigul

July 31, 2018 at 8:12 am #2597298

krisdaH

I've done all you asked and I'm still getting the error.

July 31, 2018 at 5:54 pm #2599511

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
My name is Carlos and I will be taking this ticket from now long.

I would like to ask you to recreate the page and/or check if the issue persists in another page.

If the issue persists then I kindly ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Best regards,
Carlos

August 1, 2018 at 5:50 am #2600639

krisdaH

As far as I can tell it's WPML that is causing all the problems. I can't even switch to view my pages list without getting that error never mind recreate any pages. This is after switching to another theme and disabling all other plugins.

What is the return period for this plugin? I never had these problems when I was testing another translation plugin.

August 1, 2018 at 6:13 pm #2603020

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

1.- I'm sorry to hear that the issue persists. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- In this link you will find our refund policy: https://wpml.org/purchase/refunds-policy/

Looking forward to your answer.
Best regards,
Carlos

August 2, 2018 at 1:38 pm #2605482

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I couldn't log in the site. Could you double check the credentials provided? And in case you need to change them just edit your previous message.

Looking forward to your answer.
Best regards,
Carlos

August 2, 2018 at 8:39 pm #2606985

krisdaH

Ok, please try it again. It should work now.

August 2, 2018 at 8:44 pm #2606994

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the udpate of the login credentials.

I was able to reproduce the issue. I would like to ask your authorization to make a copy of the site in order to make further tests on a local environment without affecting the live site.

Looking forward to your answer.
Best regards,
Carlos

August 2, 2018 at 8:46 pm #2606995

krisdaH

Ok, go ahead.

August 2, 2018 at 10:33 pm #2607053

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your authorization.

This issue has been reported already. Our specialists are working on a solution.

In the mid-time there is a workaround that will solve the issue. Please follow this steps:
- Go to WPML -> Settings -> How to translate posts and pages -> Select 'Use the Classic Translation Editor' option -> Save the changes.

Can you see the pages now?

Looking forward to your answer.
Best regards,
Carlos

August 10, 2018 at 5:39 am #2631955

krisdaH

I can see the pages now. When will the fix be implemented?

August 10, 2018 at 4:56 pm #2634903

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm glad to hear that you can see the pages now 🙂

When exactly our developers will release a Update including the required Fix is not up-to us Supporters to determine.

Each issue reported in is taken seriously into consideration.

It is given a high or low priority based on a number of factors.
Factors which those with the overview of all things related are in the best position to determine.

I apologize any inconvenience this may cause.

Best regards,
Carlos