This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by ericaG 1 year ago.

Assigned support staff: Bigul.

Author Posts
October 16, 2018 at 5:53 am #2819791

ericaG

Hello again!

problem of categories not showing in the translated version.
also this I've checked with my theme support and their reply is: n Italian, the links work, it only doesn't work when using the English version.
Could you please check the WPML settings, also try to contact their staff, I think it is something related to the WPML settings and not the theme itself.
you can find full details here: hidden link
original link:hidden link
translated link:hidden link
I assign to products the most detailed category (example Central Post Parasols)
after I set up all the categories with subcategories. So I have for example the category parasols-and-sun-umbrellas and inside 2 subcategory central-post-parasols and side-post-parasols.
in original language I can see the items also in the higher category more general parasols-and-sun-umbrellas and I can see the page also if there are 0 products in it.
in english the page doesn't exist.
But all subcategories and categories with products inside are working fine, so which setting I need to change to make working also the top categories? (assuming the problem is given from categories with 0 products only showing in original language...

October 16, 2018 at 4:01 pm #2821689

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Erica,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

It looks like the issue is happening because of the slug translation. Because it works as expected for the French Product Category Terms. So just for testing please use the same slug(*tipologia*) for English Product Category and check the issue is existing or not.

--
Thanks!

Bigul

October 18, 2018 at 9:34 pm #2829682

ericaG

Hi Bigul!
actually you're right, if I put back the slug to original/empty then it works!
But so, means I cannot translate the slug or is there another way?
thanks for your help!

October 19, 2018 at 3:07 pm #2832524

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Erica,

Thank you for the feedback. It looks like the issue happening because of some conflict(maybe corrupt Database entry) in slug translation. I will cross check it further and get back to you soon. Please wait.

--
Thanks!

Bigul

October 19, 2018 at 6:37 pm #2832824

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Erica,

For your kind updates, it looks like the issue is happening because of a conflict with the WordPress core functionality. The term type is included in WordPress revered terms. So it may affect queries. Please check the following documentation for more details.

https://codex.wordpress.org/Reserved_Terms

It works on your test site when I tried types instead of type. Please check it now and let me know your feedback.

--
Thanks!

Bigul

October 22, 2018 at 12:35 am #2836217

ericaG

My issue is resolved now. Thank you!