This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by ericaG 1 year ago.

Assigned support staff: Bigul.

Author Posts
October 16, 2018 at 5:50 am #2819787

ericaG

Hello again!

content block on the homepage - i've checked with my theme support and they reply to me asking to contact WPML support, here their answer:
Please try to contact the WPML team about this, our team will also contact them.
We checked your site but it seems that the settings were set correctly so we don't understand
the problem is:
I'm not able to translate the content block I'm using at the very top part of the home page...
Original: hidden link
Translated: hidden link
I've set the content as translatable at the bottom of the page, I've translated the content block, but is still don't show up in the translated version.

October 16, 2018 at 2:40 pm #2821440

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I went through the homepage in the backend and frontend of the site. But not able to track it exactly(little confused). Please check the attached image. Are you mentioning this part of the page? Please share a couple of screenshots of the issue for a better understanding.

--
Thanks!

Bigul

October 18, 2018 at 11:07 am #2827744

ericaG

Dear Bigul,
here is the screenshot of the content block.
It is the first part after header. the really first slider.
this content block is visible here, alone: hidden link
or at this screenshot:
hidden link
as you can see it is translated (not all but almost)

October 19, 2018 at 10:04 am #2831504

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Erica,

Thank you for the details. I can reproduce the issue on your site and my local copy. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

October 20, 2018 at 6:05 pm #2834487

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Erica,

The Homepage content block was not showing the translation because of a translation setting conflict. The translation preference for custom field *cesis_meta_block_content* was set as *Copy*. I have set the translation preference of it as *Translate* and translate the value(ID of English Content Block). Then the Content block is showing the translation on frontend now.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

October 21, 2018 at 11:37 pm #2836197

ericaG

Dear Bibul,
many thanks! I was able to replicate on live site and it is working now!
How can I check the name of an element to be able to solve something like this in the future?
I've tried to look for the name in class areas but is not that...
many thanks!

October 22, 2018 at 1:06 pm #2838147

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Erica,

Thank you for the feedback. Normally I use Google Chorme's *Inspect Element* feature to identify the field and classes. Please check the attached image for more details.

--
Thanks!

Bigul

October 22, 2018 at 4:12 pm #2838891

ericaG

My issue is resolved now. Thank you!