This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 13, 2018 at 5:37 pm #2732480

leeC-2

I have already finished the import, so I have to now do all the images…

How much would i need to increase the max_var_inputs to?

I am getting these errors in my log file:

A LOT of these:
Error while sending QUERY packet. PID=13705
Type: PHP Warning Line: 1924
File: /home/horstenestates/public_html/wp-includes/wp-db.php

Some of these:
Undefined index: icl_lso_native_lang
Type: PHP Notice Line: 949
File: /home/horstenestates/public_html/wp-content/themes/kleo/lib/theme-functions.php

September 13, 2018 at 5:39 pm #2732482

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I will be better able to get 2nd tier support for this issue if we handle it separately from the already escalated ticket.

So we will continue here and just to be complete, please provide the same technical info and system access information here.

Also, please indicate if the log is still growing or has the process stopped.

For your information, the normal value for max_var_input is anywhere from 1000 - 5000.

Thanks

September 16, 2018 at 7:50 pm #2739153

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Sorry for the delay to respond - we were innundated with tickets these last few days.

I did more research into the errors you reported.

1. Error while sending QUERY packet.
This error seems to be related to the size of the sql packet you are attempting to insert into the db and the PHP.ini settings. It is not necessarily related to WPML. Perhaps you can approach WP All Import supoprt for suggestions on paramters to set for large queries.

Please read the following links:
https://stackoverflow.com/questions/30753674/error-while-sending-query-packet
hidden link
https://wordpress.org/support/topic/php-warning-error-while-sending-query-packet-2/

2. Undefined index: icl_lso_native_lang
This error is being generated by your theme. It is assuming that a particular key in the icl_sitepress_settings is present in your database wp-options table...and it is not. Since this is
a theme function, you should approach your theme support and have them check if this particular function is buggy or outdated.

From what I have researched, howeer, I think your bigger problem is with the query packet size.
I hope this helps you sort things out for the import you are attempting.

September 17, 2018 at 9:46 am #2740474

leeC-2

Hi Yvette,

But the import is working fine...
It downloads the images as usual and it connects the dutch to the english as expected, all that works.

What does not work is that the images don't show - I have to delete the property, delete trash and re-import the whole feed and then then images show.

You then told me to click "set language info" under the support tab - which I have been doing, but now that button stopped working and the images are not showing, even though they have been imported.

September 17, 2018 at 12:02 pm #2740773

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK

So I understand that the error messages are there but they do not effect the import.

So we are backk to the original issue of the language tag not being added to the image import. Perhpas the "set language info" cannot handle such large nmbers(?). hmmm. In other words, there is some kind of "limit" that this tool can handle.

Does this sound more like the issue?

September 17, 2018 at 4:17 pm #2741789

leeC-2

I am not even sure...

I had an import of 8000 properties that had previously imported (like 6 months ago)
Everything was fine with that import
I updated the WPML plugin back in June
Then any import I did had just 1 image - you told me the solution to this is "set language files"
That worked

Now I did the same import of 8000 properties but had to rename the images and import an additional 5 images for each property
The import worked fine, all images are ther, I clicked the set language file, that worked ok too.

Then I imported only 20 of the Dutch properties - to check everything worked ok, - it only attaches 1 image per property and the "set language" button does not work anymore.

So I am not even importing that many, just 20 plus the images should all already be there as I imported them in a previous import...

I think this really has to do with the WPML plugin and not other items on my site as it was all working fine for a while by clicking that button...

September 17, 2018 at 8:29 pm #2742528

leeC-2

Actually Yvette, another issue has just arisen... when I am in my backend of wordpress and click on "media translation" the page doesn't load and gives me a 500 error after a while.

Everything else works, I can make changes to the site no problem, it is just when I click on "media translation"

Any idea?

September 18, 2018 at 7:50 am #2743909

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

500 errors indicate a server issue.

I would suggest that you activate the WordPress Debug to see if you can get any other details and also ask your hosting support for assistance. They may be able to see system logs for an indication of what might be happening.

The topic ‘[Closed] Split: Database error on website – large import stuck with lots of DB and PHP errors.’ is closed to new replies.