This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.30 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by julizarS 1 year ago.

Assigned support staff: Bigul.

Author Posts
October 5, 2018 at 2:54 pm #2791143

julizarS

Hallo Bigul..

Please also check "Menu language switcher" Now I have remove it from the setup: hidden link if I add it, there are two menu switcher available on menu. See video screen: hidden link

Thanks

October 5, 2018 at 3:37 pm #2791229

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I have downloaded the Duplicator copy of the site now. Will debug the issue further on my local server and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 5, 2018 at 11:28 pm #2791897

julizarS

Thaks for your help and please do your best to help me

Thanks

October 8, 2018 at 4:22 pm #2796926

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, I can reproduce the issue on my local copy. It looks like RealHomes theme is adding a WPML Language switcher by default. So I need a help to confirm it. Please share me the latest version of RealHomes theme(the fresh download copy). You can share it via Dropbox or Google Drive. I am enabling the private option for the next reply.

--
Thanks!

Bigul

October 10, 2018 at 5:46 am #2802981

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the theme files and the details. I will check it further and get back to you soon. Please wait.

--
Thanks!

Bigul

October 10, 2018 at 4:46 pm #2805242

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the Realhome theme is showing WPML Language switcher in a fresh installation also(without adding any extra settings). Please check the attached image.

Therefore I will check with our compatibility team and get back to you soon. Please wait.

--
Thanks!

Bigul

October 12, 2018 at 8:04 am #2811074

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, I have escalated the ticket to our compatibility team for further checking. We will get back to you as soon as possible. Please wait.

The default language switcher from RealHomes is not showing in my local copy after the following steps. You can consider it as a workaround for the time being. Because RealHomes language switcher options are not able to change from WPML>>Languages>>Custom language switchers.

1) Visit *wp-content/themes/realhomes/assets/modern/partials/header* folder
2) Open *header.php* file for edit
3) Scroll down to line *75* and make the following change

From

inspiry_language_switcher();

To

//inspiry_language_switcher();

4) Save the changes and visit the frontend

--
Thanks!

Bigul

October 15, 2018 at 3:09 pm #2818032

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, we got an update from the theme author on this. We can control the RealHomes language switcher options from Themes>>Customize>>Header>> User Navigation. Please choose *Hide* option for *WPML Language Switcher Display*.

Please check the attached images for more details and let me know your feedback. You can reverse the changes in wp-content/themes/realhomes/assets/modern/partials/header/header.php file now.

--
Thanks!

Bigul

October 17, 2018 at 2:59 am #2823024

julizarS

My issue is resolved now. Thank you!