This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by juan-luisV 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
August 5, 2019 at 7:47 pm #4342887

juan-luisV

Hello Bobby, I managed to fix the issue by testing each plugin one by one. However, I have another issue. On the homepage, the Visual Composer is not loading on the front end. This error is only for this page, it works perfect on every other page. Any ideas?

August 5, 2019 at 7:50 pm #4342893

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

When the error happens with the visual composer do you get a fatal error in the front end or does it just remain reloading ?

if you right click and inspect the page, do you see any errors within the console log?
(right click->inspect->console tab)

As the credentials have been automatically been removed from the previous ticket by our system if possible please provide me with access to the site so i can take a closer look

August 7, 2019 at 8:12 am #4352625

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I was able to set up your site on my local environment to further test it

The issue happens only when a page is set to Home Page

for example if you change your Home Page to "Nuestro Equipo" then you will be able to access the inicio Visual Front End editor and not the "Nuestro Equipo" one

There is a Notice that i am getting that might be the reason for this , i am currently debugging this and will update you shortly !

Notice: Trying to get property 'comment_status' of non-object in /Applications/MAMP/htdocs/t/wp-includes/comment-template.php on line 1221
August 7, 2019 at 9:56 pm #4358429

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i was able to test this issue with a newer version of WP Bakery Page Builder and it was resolved

you are using an older version of WP Bakery Page Builder 4.1.1 and since that version there has been some compatibility fixes introduced to the plugin for WPML

=> hidden link

you can see in my screenshot that the Visual Composer is working on the front end as expected
(dont mind the notices/warnings this is because i am on my staging environment with debug on )

please update your page builder plugin and let me know your results (usually updating the theme to its latest version updates the page builder as well if you dont have a license to wp bakery page builder )

August 8, 2019 at 5:30 am #4359733

juan-luisV

Wow Bobby, that's great news. I just went ahead and download the zip file for the updated WPBakery Page Builder. Do you wanna try it first on your side to see if it works fine? and if so, can you help me install it on my site? Since I downloaded the zip file, wordpress doesnt allow me to update the plugin using a zip. Here is the link to the zip file:

hidden link

Thank you!!

August 8, 2019 at 10:27 pm #4366205

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I can confirm that on my environment it worked as expected with the latest version you provided me

August 8, 2019 at 10:36 pm #4366211

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have uploaded the new version on your site as well.

to do this i installed WP File Manager plugin as i did not have access to your FTP

August 9, 2019 at 12:31 am #4366351

juan-luisV

Bobby you guys are the best! I just saw the issue has been fixed and our homepage WPbakery builder is loading perfect. I truly appreciate your close attention to this, great support!!

August 9, 2019 at 12:33 am #4366353

juan-luisV

My issue is resolved now. Thank you! great support! Bobby went truly out of his way to help us.