Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Alejandro 3 weeks, 5 days ago.

Assigned support staff: Alejandro.

Author Posts
October 30, 2019 at 11:33 am #4855015

yuriH

Having the same problem here. Updated WPML and all its components to the most recent version, error occurs when Woocommerce Multilingual 3.7.1 is active. Even when I deactivate all other plugins on that site, the error is still there. Site is unaccessible, seems like a 500 error.

October 30, 2019 at 12:25 pm #4855573

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

Please follow the instructions mentioned on this page: https://wpml.org/documentation/support/debugging-wpml/

Try to recreate the problem once you have added those lines to your wp-config.php file and then go to your installation's wp-content folder and find the "debug.log" file that should've appeared by now (it will appear if it enocunters an error in your server).

Then, upload that file into a storage platform of your choosing (Google Drive, Dropbox, etc) and send me the link (make sure it's set as "public" otherwise i won't be able to access its content) so i can download it and take a look at it, and determine where to go from there.

And also please provide me with information about your environment by following these steps: http://wpml.org/faq/provide-debug-information-faster-support/

add the debug information on the field i just enabled for you

Thanks in advance.

October 30, 2019 at 12:37 pm #4855659

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, the problem is most likely in the template of the currency switcher and we have already identified the problem.

Please check if the workaround on this errata fixes the issue for you: https://wpml.org/errata/visiting-product-page-or-a-page-where-currency-switcher-is-present-could-produce-an-error-with-woocommerce-multilingual-v-4-7-0/

Regards.

August 25, 2020 at 2:36 pm #6869669

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm not sure if you got any notification about this but i just wanted to confirm that the problem has been fixed already.

I hope it's your case as well.