Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by dawnP-2 4 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
July 22, 2019 at 1:24 pm #4257889

dawnP-2

Hello there!

There is an error showing up when I want set the initial language for media. See screenshots! Perhaps this is why 1) to 3) is not working ?!

My steps:
--> In the backend I see the message that I have to set the initial language.
--> I click the button > Mediensprache festlegen
--> I start > Medien-Übersetzungs-Dokumentation
--> the error message occurs: please try again later

Can you help me?

Thank you,
D

July 22, 2019 at 1:26 pm #4257897

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

I realise that you have already provided this information on the previous ticket. But we ask that this information be attached to each ticket on the forum. Thanks for your cooperation in this matter.

July 22, 2019 at 3:27 pm #4259519

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

This is very strange. I can see that a 500 server error is being generated. (see image)

I also found a number of "ghost" entries in our icl_translation table for images that were non-existing on your current site. I reinitialised the icl_translations table so that the media would be picked up as if new...and still it fails.

Would you please ask your server support to send you the messages in the server log? We don´t have access to that information/log, so this could be very helpful.

July 25, 2019 at 10:51 am #4281945

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thanks for the log. I think I may have found some of the issue but I need your assistance to resolve it.

I have tried to use a database plugin but it is not allowing me to do the required action.

Using your CPanel PHPmyAdmin, please access the icl_translations table and delete the entry where element_id = "427" (see image).

Once this is done, could you please notify me? Thanks

July 25, 2019 at 11:13 am #4282357

dawnP-2

Ok, I deleted the entry!

July 25, 2019 at 1:12 pm #4283405

dawnP-2

Are you working on my issue? All the Portfolio Items are gone.
See screenshot of the state before.
I just wanted to make the translations for that.
Now I wait and I am hoping every item is coming back....

July 25, 2019 at 2:09 pm #4284055

dawnP-2

The error-issue is no more there, actions in wpml which I could not handle before are working now. But the portfolio items are still gone. Just one left. What can I do?

July 25, 2019 at 2:54 pm #4284413

dawnP-2

Sorry, it's me again.
I took a look in the database. In wp_posts I can still see the portfolio items. Also I see all the pictures in the media library.
But why can I only see ONE portfolio item in the frontend?

July 25, 2019 at 3:32 pm #4284799

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

I looked as well. For some reason, the icl_translations table does not have the rest of the items there and, again, when I run the tool to assign the language code, the 500 error comes up.

With regards to the media settings - this is now fixed and completed.

So, could you please, again, check the server log and forward to me so that I can see what error might be happening?

July 25, 2019 at 4:54 pm #4285257

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

Ok - this was a similar issue, this time with post-id = 430

I was able to fix it with ARI Adminer.

Now you can see the portfolios - please review that the correct language assignment is present. You can change language of the portfolio within the native wordpress editor in the Languages sidebar.

July 25, 2019 at 5:40 pm #4285401

dawnP-2

Ok, thank you!!!!!! Great! Everything seems to work fine.
Can you tell me why there are such strange problems? Was that my mistake?

July 26, 2019 at 7:52 am #4288037

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Great!

To answer your question - I am not sure really. Was this system "migrated" by any chance?

The issue is that, for some reason, the icl_translations table saw certain post-ids as a different post type than what they were. Specifically, WordPress stored them as "attachment" but the translations table had them as "revisions" or did not have them at all.

How do the tables get mis-aligned? Sometimes ghost entries remain in our tranlsations table after a migration or after deleting images (??). Suffice to say that there are some conditions where the tables get out of synch.

In conclusion, hard to say that it was anything that you did in particular but rather a set of conditions that sometimes leads to table mis-alignment.

July 26, 2019 at 9:21 am #4288611

dawnP-2

OK, thanks for answering.
I did not make a migration, because I want to have everything new without old stuff!
Thanks a lot! I'm happy with that.

July 26, 2019 at 9:23 am #4288617

dawnP-2

My issue is resolved now. Thank you!