Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client was experiencing issues with the language switcher in the footer not displaying correctly, and the English language option was missing or not displaying all menu items when selected.

Solution:
1. We recommended checking the theme as it might be causing the issue by adding content to the Menu item title. We suggested contacting the theme provider for assistance.
2. Alternatively, we advised using a Custom Language switcher instead of the Menu Language switcher, with guidance provided in the following documentation:

3. We identified a memory issue and increased the memory limit by adding the following code to the wp-config.php file:

define ('WP_MEMORY_LIMIT', '256M');<br />define ('WP_MAX_MEMORY_LIMIT', '256M');

4. We performed several troubleshooting steps in WPML -> Support -> Troubleshooting, including clearing the cache and fixing translation tables.
5. We published the English homepage which was set as a draft and cleared the WP-ROCKET cache.
6. We instructed the client to ensure all pages are published and to resync the menu by going to WPML > Menu Sync.

Please note that the solution provided might be irrelevant due to being outdated or not applicable to your case. If the issue persists, we highly recommend checking related known issues, verifying the version of the permanent fix, and confirming that you have installed the latest versions of themes and plugins. If you need further assistance, please open a new support ticket.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 4 voices.

Last updated by magdalenaW-5 2 months, 2 weeks ago.

Assisted by: Alejandro.

Author Posts
March 19, 2024 at 6:14 pm #15428330

Subash Chandra Poudel

Hi there,

Thank you for the details.

I tested the issue further and it looks like the issue is caused due to the theme you are using.

Your theme seems to be adding the content of the Menu item as the title of the link to it which causes the issue. In this case I recommend you yo contact the theme provider and see if they could help.

Or you can also use a Custom Language switcher instead of the Menu Language switcher as explained in the next links:

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/custom-language-switcher/

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/adding-language-switchers-using-php-and-shortcodes/

Regards,
Subash

March 19, 2024 at 6:19 pm #15428374

Lucas Vidal de Andrade
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

About the Footer Language Switcher, I tested it in 2 browsers, in incognito mode and the language switcher was functioning as expected. Can you confirm the issue is still happening on your side?

If the client specifically can't see it, it might be due to some local configuration. Try asking him to check it on other browsers or devices, if possible.

I'm waiting for your feedback.

March 22, 2024 at 10:11 am #15439693

magdalenaW-5

Hello Lucas,
language switcher is now moved from the footer (thanks to the ticket [ https://wpml.org/forums/topic/the-menu-is-displayed-in-the-form-of-html-code/ ]) but the issue with missing "English" still remains.
As an administrator, I have 'English' visible on the language list (when I'm logged in), but other colleagues don't see it (~10 people checked on different browsers).

Best regards
Paweł Uliczny

1.png
March 22, 2024 at 1:23 pm #15440649

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

To investigate the issue, I kindly ask you to grant me access to the wp-admin area of your website.

I have enabled the necessary fields on my end so you can provide them to me in a secure and private manner. This way, only the two of us will be able to view them.

If possible and for your safety, i'd suggest you create a new user (a fake one with a fake mail) that you can later delete when the ticket is closed.

March 22, 2024 at 1:24 pm #15440651

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

You should be able to see the credentials field now.

April 3, 2024 at 6:59 am #15476257

magdalenaW-5

Hello Alejandro,
is there any progress with this issue?

Best regards
Paweł Uliczny

April 3, 2024 at 8:11 am #15476689

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!

For some reason, the ticket was never updated so i never saw your last message! i'm not sure what's happening but i'm making sure it doesn't happen again.

1) I checked your site and the first issue is memory, you don't have enough memory to cover for our minimum requirements and you're also using way more than you have available.

WPML needs a minimum of 128MB of memory to work correctly and it seems you are not meeting this requirement.

i added this code into your wp-config.php file, right after the database information:

 

define ('WP_MEMORY_LIMIT', '256M');
define ('WP_MAX_MEMORY_LIMIT', '256M');

to make sure we cover enough memory

2) I then went to to WPML -> Support -> Troubleshooting

Pressed the following buttons:

• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix post type assignment for translations"

3) Finally i went to the english homepage and noticed it was set as a draft so i published it.

4) Cleared the WP-ROCKET cache and that was it, it appeared even as incognito

Can you check and let me know if it's fixed on your end as well?

April 3, 2024 at 1:59 pm #15478883

magdalenaW-5

Hello Alejandro,
looks like the English language is now visible in the language switcher but once selected it just shows "Home" button and language switcher next to it (About us / Offer / Contact are missing).

Is it possible to update EN menu somehow?
When I'm logged in as admin after choosing 'English' from the language switcher everything works like intended but in incognito mode I can see only "Home".

Best regards
Paweł Uliczny

menu.png
April 3, 2024 at 4:27 pm #15479557

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

First of all, make sure all those pages are published. It's very likely you have all those pages set as draft (if you edit the English version of those pages and see the "publish" button text instead of "update", then it's a draft).

Once that's done, resync the menu by going to WPML> menu sync (you can use the link I sent earlier to find images and all the steps to do it in case you get stuck).

That should do it 🙂

April 4, 2024 at 10:20 am #15482291

magdalenaW-5

Thanks a lot for the tips and your help 🙂
Everything is working fine right now.

Best regards
Paweł Uliczny

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.