Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by davidD-102 1 month, 2 weeks ago.

Assigned support staff: Igor.

Author Posts
November 29, 2019 at 2:50 pm #5044057

davidD-102

Hi, I am getting website loading issues today and its due to WPML so can you please check why we are getting too much CPU usages and how you will increase the performance of website? Please dont tell to create new ticket. I want to stay with only one support guys. Its get too much time wastage when we contact to another guys.

November 29, 2019 at 2:53 pm #5044107

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
I split the ticket because this issue is different from the original one.

1.- Could you explain why WPML is causing this performance issue?

2.- Does the issue persists in a minimal setup with only WPML plugins active and a default WordPress theme?

Best regards,
Carlos

November 29, 2019 at 3:14 pm #5044353

davidD-102

Hi,

thankyou for this.

we are getting high cpu usages, our sale is going website. we have traffic now but this problem we faces last time too and your support team help me to resolve.

I am also getting this notification in top too so please check this issues in urgent bases.

REST API is disabled, blocking some features of WPML
It looks like the WordPress REST API is disabled on this site. This blocks some features of WordPress itself and of WPML.

I am getting this error too. please check

November 29, 2019 at 3:58 pm #5044735

davidD-102

any updates?

November 29, 2019 at 5:46 pm #5045351

davidD-102

I checked your official website and its also having many languages but its smooth where as our is not so please check deeply and let me know if we did with any wrong way.

December 2, 2019 at 11:28 am #5052729

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

1.- The issue related to the error message should be solved by updating the WPML plugins to the latest version and setting up Translation Management plugin if you haven't already.

2.- Regarding the performance issue, I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any- change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

3.- As mentioned in the other ticket, please double check the wp-admin credentials provided and restore the ones shared because I can't log in the site.

Regards,
Carlos

December 3, 2019 at 12:09 am #5057279

davidD-102

Hi,

Thank you for your response.

I have tried all the way. I will back the website too but I think it's you need to check for these issues.

Please share private message, I will add login info there. I changed these for another security reasons.

Thank you

December 3, 2019 at 8:47 am #5058393

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

I have set your next answer private.

Regards,
Carlos

December 4, 2019 at 11:57 am #5067981

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,

I applied some troubleshooting steps and the performance issue disappeared.

Could you confirm that the performance of the site is back to normal?
Regards,
Carlos

December 4, 2019 at 5:42 pm #5071277

davidD-102

OK, Could you please tell me what issues you found and what you performed so that I will take for next time.

December 4, 2019 at 5:56 pm #5071313

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

Yes sure. I went to:
- WPML -> Languages -> Deactivated "Make themes work multilingual" option.
- WPML -> Support -> Troubleshooting link and Applied the troubleshooting steps highlighted in the attached image.

Best regards,
Carlos

December 5, 2019 at 3:50 pm #5078137

davidD-102

OK, do you suggest any suitable plugin to replace this one for facebook pixel issue? We will need this service on our website. I think many users may be getting this issue. Also please let me know the solution for this too.

December 6, 2019 at 9:03 am #5082043

Igor
Supporter

Unfortunately I do not know which plugins have similar to Facebook Pixel functionality. I think alternatives can be found in official WordPress repository. You can check performance impact of this or similar plugin by activating/deactivating it, or analysing long queries by Query Monitor plugin. Please do not forget to deactivate Query Monitor plugin after analysis, as it takes some significant time to load by itself.

What I would like to say: the issue with Facebook Pixel plugin is not related to WMPL at all. Plugin just generates some inefficient queries to database.

My fix to WPML core plugin is under review now, and will be included into 4.4.0 release. In principle, I can prepare a beta version of the plugin for you, but please take care and try it first on test copy of your site. My advise, however, is to wait for WPML 4.4.0 release.

December 9, 2019 at 6:53 pm #5095337

davidD-102

hey, why you dont try anything at your end?? I have staging site and live site credentials.

December 10, 2019 at 2:45 pm #5100821

davidD-102

how you can mark thread fixed without fixing all issues???????????????