Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Strings from the Uncode (WPBakery) elements are not showing for translation in the Translation Editor.

Solution:

The Uncode theme is using its special WPBakery elements. The wpml-config.xml file for those elements was removed (to the request of the Uncode author), and therefore the elements are not translatable with WPML's Translation Editor.

From our side, currently, we can only suggest the following.

1. We have two files that need to be in the Uncode theme folders for things to work with WPML.

2. Copy those files from our GitHub repository here:

A. https://github.com/OnTheGoSystems/wpml-config/blob/master/uncode/wpml-config.xml

And here: B. https://github.com/OnTheGoSystems/wpml-config/blob/master/uncode-js_composer/wpml-config.xml

Place the A file in the wp-content/themes/uncode/ root folder. And the B file in /wp-content/plugins/uncode-JS_composer/ folder.

3. Now things should work with WPML, and you suppose to be able to use the Translation Editor and see the strings for translation.

This topic contains 21 replies, has 2 voices.

Last updated by torsten3d 8 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
February 28, 2019 at 10:32 pm #3257596

torsten3d

Hi Itamar,

after changing the Font-Size for the heading with the counter (the bigger size caused a line break than counting) i just see the german words on the English frontend again.

Additionally the text block below is also german again and not visible in the translation editor anymore!

Best regards
Torsten

February 28, 2019 at 10:42 pm #3257612

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Torsten.

In our forum, we try to keep one issue per ticket.
Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster. Therefore, I've split the other ticket and created a new ticket with this issue.

I can see this issue on your site.
How di you change the Font-Size for the heading?

Currently in WPML -> Settings -> Wie Sie Beiträge und Seiten übersetzen the option 'WPMLs klassischen Übersetzungs-Editor verwenden' is chosen.
Was it always like this or is it possible that you have changed the Translation method?
Were you first translating the page with the ATE?

Note: today we have released a new version of WPML 4.2.4.1. Please update to this version.

Thanks,
Itamar.

February 28, 2019 at 11:14 pm #3257669

torsten3d

Hi Itamar,

Font-size changing is explained in Screenshot.
I already changed it from 48px to 40px some hours ago.

I mostly used ATE for that the whole site and also directly for that specific site. Some sites like "impressum" are translated by copy, and homepage (Startseite) also was translated with ATE, but later (accidentally) switched to the classic translation view.

Othe pages which now also suffer from not translated text blocks which are not in the editor are 100% ATE-Edits all the time.

February 28, 2019 at 11:15 pm #3257670

torsten3d

sorry - here is the Screenshot

March 1, 2019 at 1:10 am #3257822

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

So probably what caused the problem is the accidental switch to translate the pages with the CTE instead of the ATE. The translations are probably kept on the ATE. Here is what you need to do to correct it.

1. Go to WPML -> Settings -> Wie Sie Beiträge und Seiten übersetzen and in 'Inhalt, der mit WPMLs klassischem Übersetzungs-Editor erstellt wurde' change the option 'WPMLs klassischen Übersetzungs-Editor verwenden' to 'Zum erweiterten Übersetzungs-Editor wechseln (alte Übersetzungen könnten dann unbrauchbar werden)'.

2. Go to edit the original page and make a small change (you can simply add a space in one of the elements). (This will trigger the need also to update the translation.

3. Update the page by pressing the 'Update' button.

4. Press the English language to edit the English translation. Now you should get the ATE.

5. Finish the translation with the ATE.

Now all the English strings should be back on the English page.


**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

March 1, 2019 at 8:37 am #3258939

torsten3d

My issue is resolved now. Thanks for your support! 🙂

March 1, 2019 at 7:41 pm #3262988

torsten3d

I Itamar,

i found out that the backup has the same problem here. The text-blocks from the Pages (just seems to affect the WP Bakery Text blocks "uncode_text_column") are not visible in the translation. Neither in CTE nor in ATE.
Even if a create a brand new page with just a row and 1 text block in it with some sentences - just the Page title is there for translation (screenshot)

March 4, 2019 at 1:11 pm #3268830

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

You wrote: "i found out that the backup has the same problem here."
I'm sorry but I do not understand which backup has this problem.

You have marked this ticket as resolved and then re-opened it.
Has the problem returned?
Can you elaborate on this issue, please?

Thanks,
Itamar.

March 4, 2019 at 7:31 pm #3270471

torsten3d

Hi Itamar,

sorry for the confusion.
Yes, the problem returned or wasn't really completely solved after importing the backup.

So the problem now, like before is, that some text blocks (just seems to affect the WP Bakery Text blocks "uncode_text_column") are not visible in ATE or CTE. I switched it some times like you have described.

I also tested now a new page with just an text block. Translation is just visible for the page title, the first time i click on translation.)

Best regards
Torsten

March 5, 2019 at 4:08 pm #3275054

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Torsten.

I can see that you are using a child theme.
Are you using the latest version of the Uncode parent theme?
If you are using the latest version and the problem persists then here is the full explanation of the problem.

We have an issue with this theme, and I'll explain it now.
The theme is officially compatible with WPML, and you can see it here.
https://wpml.org/theme/uncode/
Whenever a WPML user is using the Uncode theme, it loads the WPML configurations.
It loads it from our CDN here.
hidden link
Recently, the developer of the Uncode theme has contacted us and asked us to disable the loading of that file. Please see a reference for that here.
https://wpml.org/it/forums/topic/problem-with-string-translation-and-xml/
So we have disabled the loading of that file, and the developer of the theme was supposed to update the files in the theme folders for things to continue to work normally with WPML. But it seems that this is not done yet. We have another forum ticket with this issue. Please see it here.
https://wpml.org/forums/topic/wp-bakery-are-not-picking-up-elements-when-translating/

From our side, currently, we can only suggest the following.

1. We have two files that need to be in the Uncode theme folders for things to work with WPML.

2. Copy those files from our GitHub repository here:

A. hidden link

And here:
B. hidden link

Place the A file in the wp-content/themes/uncode/ root folder.
And the B file in /wp-content/plugins/uncode-JS_composer/ folder.

3. Now things should work with WPML, and you suppose to be able to use the Translation Editor and see the strings for translation.

Please let me know if it is working for you.

If you can please also contact the developer of the Uncode theme and ask him to correct this issue as it is in his hand now.

Regards,
Itamar.

March 6, 2019 at 8:06 pm #3281196

torsten3d

Hi Itamar,

small update from my site. Cause my client has an ad in a local newspaper this weekend i had to solve some problems today.

So i gave another try to reload a lasts week server-backup and somehow i managed it to work properly now.
Fact on hidden link is now a fully translated site. 🙂
Theme is now Uncode 1.9.1. Al text block could be translated - better - they had the already made translation in place.
I didn't updated any plugin or theme after installing this backup and stop doing this, till we have a good solution.

Before backing up, i transferred the site to my own test server.
It's now available at hidden link with all problems we saw before. Theme is actual there - so this could be a good place for further tests.

So - if needed i'll give yout he new credentials for admin and ftp.

Best regards
Torsten

March 6, 2019 at 10:05 pm #3281463

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hey, Torsten.

Thank you for this update.
I'm glad that for now things are working and your client can publish the ad in the newspapers.

Best Regards,
Itamar.

March 26, 2019 at 2:22 pm #3463407

torsten3d

Hi Itamar,

do you have some news or for me? The problem still exists on a second page (www.seko.de with all updates so far).

I still didn't started any update on hidden link since i could recreate the working status it had before the issue / updated came.

Best regards
Torsten

March 27, 2019 at 3:38 pm #3472911

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Torsten.

There is no change from what I wrote in my reply here.
https://wpml.org/forums/topic/split-german-string-show-on-the-english-page/#post-3275054
The author of the theme still didn't come back to us.
You would need to follow the instructions in my reply on how to make things work with the Uncode theme.

Please let me know if you need help with that.

Best Regards,
Itamar.

March 28, 2019 at 4:43 pm #3484017

torsten3d

Hi Itamar,

i didn't got the problem solved by adding/changing the files.
It seems my message got lost there i already wrote this - it isn't here in the timeline.

Iplaced both files exactly where you said.
Checked twice if A and B are the right version.

You can check on my testsite if you wan't.
I'll give you all credentials if needed.

Kind regards
Torsten