This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

How to do the translation for the cookie notice plugin?

Solution:

1) Copy the following code in WPML->Translation Management -> Custom XML configuration

<wpml-config>
    <admin-texts>
        <key name="cookie_notice_options">
            <key name="message_text"/>
        </key>
  </admin-texts>
</wpml-config>

2) Once you place the code there, go to WPML->Translation Management -> Multilingual content setup and refresh the page.

Once you have created language configuration files, you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate it into the secondary languages.

This topic contains 4 replies, has 2 voices.

Last updated by inkenP-2 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 14, 2019 at 7:33 pm #3810359

inkenP-2

Hi again,

last week the whole website worked in english. But after the WP update, the home page doesn't show the translations: hidden link
What do I have to do?

I also don't know how to do the translation for the cookie notice plugin?

Thanks, Inken

May 14, 2019 at 7:39 pm #3810379

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

In our forum, we try to keep one issue per ticket.
Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster. Therefore, I've split the other ticket and created a new ticket with this issue.

Could you please elaborate on what you are trying to translate with the cookie notice plugin?
Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.
Did you search for those strings from the plugins in the String Translation section?

Regards,
Itamar.

May 15, 2019 at 10:50 am #3815199

inkenP-2

Hi!
When you load hidden link then you see the cookie notice in German. The translation is not shown (I added an English translation into the German translation, so it's bilingual).

Thanks
Inken

May 16, 2019 at 12:20 pm #3825745

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Here is a solution from another forum ticket that helped a user which is using the same cookie notice plugins that you are using — the Cookie Notice by dFactory.

1) Copy the following code in WPML->Translation Management -> Custom XML configuration

	<wpml-config>
		<admin-texts>
			<key name="cookie_notice_options">
				<key name="message_text"/>
			</key>
	  </admin-texts>
	</wpml-config>

2) Once you place the code there, go to WPML->Translation Management -> Multilingual content setup and refresh the page.

Once you have created language configuration files, you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate it into the secondary languages.

Please see if this information is helping you to solve the problem.

Otherwise, if you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

May 22, 2019 at 7:38 am #3862615

inkenP-2

My issue is resolved now. Thank you!