This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I need to translate the HTML block and tab that are integrated via the Theme options.

Solution: You can try to translate the field using String Translator to replace the shortcode on the secondary language. Please try the steps below: - Make sure you have the Translation Magagement and String Translator extensions active. If not, you can download here: https://wpml.org/account/downloads/ - Go to WPML > Theme and Plugin Localization > Strings in the themes - Select your theme and click on Scan selected theme for strings - Go to WPML > String Translation and search for the Strings - Translate the string, check the Translation is complete field and click on Save.

Ref: https://wpml.org/documentation/getting-started-guide/string-translation/

>>> If you can not find the strings, check it is possible to find it on the Translate texts in admin screen page, like on this link: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

This topic contains 4 replies, has 2 voices.

Last updated by alinam-2 8 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
January 2, 2019 at 6:26 pm #3050184

alinam-2

hi Diego,
Happy new year!
I found how to make it. The translation -as you wrote it - works. The integration in the footers is achievable via menu / widgets.
Now is the issue of the HTML block and tab that are integrated via the Theme on product pages.
Those are configured via theme Settings / product page.
Waiting for your feedback,
Kind regards

January 2, 2019 at 6:33 pm #3050202

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please try the following:
- Go to Theme Settings > Product Pages (on original language)
- Change the language using the Language switcher at the top admin bar
- Scroll down to After "Add to cart button" text area and replace the html_block shortcode id with the ID of the translated version of the block
- Save

Please let me know if it worked for you.

Kind regards,
Diego

January 2, 2019 at 9:13 pm #3050565

alinam-2

Hello,
I just tried. If you talk about the icon that is shown below, it does not work. Any change on any language is automatically made on the other language(s).
Sorry. Do you see any other way?
Kind regards

January 3, 2019 at 12:16 pm #3052409

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

You can try to translate the field using String Translator to replace the shortcode on the secondary language. Please try the steps below:
- Make sure you have the Translation Magagement and String Translator extensions active. If not, you can download here: https://wpml.org/account/downloads/
- Go to WPML > Theme and Plugin Localization > Strings in the themes
- Select your theme and click on Scan selected theme for strings
- Go to WPML > String Translation and search for the Strings
- Translate the string, check the Translation is complete field and click on Save.

Ref: https://wpml.org/documentation/getting-started-guide/string-translation/

>>> If you can not find the strings, check it is possible to find it on the Translate texts in admin screen page, like on this link: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Please let me know if it worked for you.

Kind regards,
Diego

January 4, 2019 at 10:11 am #3055785

alinam-2

My issue is resolved now. Thank you!