Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
January 24, 2019 at 3:13 pm #3125833

judithV-7

Hi Yvette, I´m practising translating pages but I´m having problems with the dimensions of the images. It copies the images but the dimensions are different.

The websites of the pages are: hidden link and the Spanish translation: hidden link

Could you have a look at this?

Thank you,
regards,
Judith

January 24, 2019 at 3:34 pm #3125915

judithV-7

Hi Yvette, thanks for your answer! But I think I´ve solved the problem. It has something to do with the fields the advanced translation editor automatic translates while it should only copy the texts.

January 24, 2019 at 4:13 pm #3126047

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

As this is a pagebuilder element, it may be that the information you need to transfer is not seen or picked up by the translation editor.

The best way to translate pagebuilder pages to be sure to get all styling the same is to create a WPML duplicate to the target language and THEN translate it independently with the translation editor.

This is what I did to create this page from a cloned NL page of the example you provided:
hidden link

Notice how the image meta information is the same. Then I only have to translate the words.

Note, as you have set your translation options for pages to "appear as translated", you will need to create the wpml duplciate using Tranlsation Management dashboard.

January 25, 2019 at 11:46 am #3128787

judithV-7

Hi Yvette, thanks so far!
Is it really necessary to duplicate all the pages? Then we will get a lot of pages!! I actually didn´t know I´ve set the translation options for pages to appear as translated. Would you recommend me to change that?
I´m trying to translate pages with the translation management, from the dashboard the page goes to the basket, but if I send the page from the basket to translate is doesn´t appear in the translation jobs list. How is this possible?
Thanks, Judith

January 25, 2019 at 12:16 pm #3128845

judithV-7

And if I try to translate a page without translation management it says hidden link can´t do it (HTTP error 500)

January 25, 2019 at 12:17 pm #3128846

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

DUPLICATION
If you are creating translations, duplicating the content is the most sure way to copy all of the items that you cannot see (like the layout settings, post-meta information). Think of it as a "starting point" for your final translation.

The "duplicated" page gets transformed into a translation so there are no "extra" pages being created just because you started creating a translation via duplication.

TRANSLATION MANAGEMENT PROCESS
If you are not using external translators...or if you are working alone on translating the site, using the Translation Management system might be "overkill" in my opinion. You can translate with the ATE and Tranlsaiton Editor directly from the post without having to create a trnaslation job.

The TM system is mostly for cases where there are other users who only translate or if you are using external translators.

APPEAR AS TRANSLATED
This mostly makes sense when you have a shop or content that is not language sensitive. For example, a photographer whose site shows portfolios of images. If you want/do not mind that your pages are visible in the default language even if the visitor is using a secondary language, then you need this option "appear as translated".

However, if you wish visitors to only see content in the language they are using, then you should not use this setting.

TRANSLATION JOBS
I would need an example to understand what you mean. However, I just checked the translation jobs and I see entries and 1 item in the translation basket that is not yet assigned to anyone.

January 25, 2019 at 12:32 pm #3128881

judithV-7

Hi,
I´ve been trying this morning to get translations from the basket to the translation jobs (sent items to translation) and I didn´t manage to do it. As you can see the last job which entered in the joblist is your example of yesterday. See images attached. It says the batch is ready, but it doesn´t appear in the jobs list.
And if I try to translate a page without the translation management it says hidden link can´t do it (HTTP error 500)

January 25, 2019 at 1:43 pm #3129145

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Ok.

You do not see it because that was the "Duplication" that I executed. This does not create a "job" normally because it is only creating a new post as a duplicate of the original language post so there is no translation required.

But do you have other jobs that you have sent that are not appearing in the translation list?
e.g. another example that is not my own job

Maybe you can uypload a screencast for clarity?

January 25, 2019 at 3:18 pm #3129575

judithV-7

The images I sent to you show another job which is not appearing in the translation list. All the pages which I´m trying to translate don´t appear in the translation list.

AND if I try to translate a page without the translation management it says hidden link can´t do it (HTTP error 500).

January 25, 2019 at 3:52 pm #3129680

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hmm - I am not getting a 500 error. I just created a translation of the Disclaimer page here:
hidden link
hidden link

In order to simplify the translation, I swtiched your editing mode to use the Classic Translation Editor. I also activated the Classic Editor plugin that you had installed. Finally, I temporarily activated a language switcher in your footer so that I can show you the process here in a screencast:

hidden link

HOWEVER, I do see that after saving the translation, the editor goes blank....and the content is not fully updated...so here there could be an issue. But I thought you should see the screencast to understand how you can translate without using Translation Management - translation basket...etc.

Could you please enable WordPress debug mode by adding/changing the following line in you wp-config.php file:

define( 'WP_DEBUG', true );

Please let me know when this is done and then we might get more information on the 500 error.

January 30, 2019 at 11:16 am #3143461

judithV-7

Hi Yvette, sorry that it took so long, but I needed the help of my webhosting company to enable WordPress debug mode. It´s done now, so you can have a look, if there´s a issue on our website.
Regards,
Judith

January 31, 2019 at 9:37 am #3146970

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

Thanks for activating the debug mode. I am still not seeing any 500 error...but a lot of warnings are showing up which are not errors...but notifications.

If you are still getting a 500 error, please either upload a screencast that shows the steps you are executing --OR-- write step-by-step instructions taht I should execute to see the same error.

Thanks

January 31, 2019 at 10:10 am #3147148

judithV-7

Hi Yvette, if I try to translate a page (without translation management), this is what I see....

January 31, 2019 at 12:53 pm #3147928

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hmmm

I see now.

Can you try temporarily switching your URL format to use a language per directory (you currently have it set for a language per domain).

I just want to see if this has anything to do with the URL format in use.

Thanks!

January 31, 2019 at 1:08 pm #3148011

judithV-7

Done!