This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
January 31, 2019 at 4:53 pm #3148940

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thanks - unfortuantely, it still is not working. Would it be ok to keep it in this format for a while as I troubleshoot the problem?

Is anyone else working on the site -if I need to deactivate plugins, should I wait until off-hours to do this? Or could you give me a time frame where it would be possible?

THanks

January 31, 2019 at 5:09 pm #3148994

judithV-7

It is ok to keep it in this format. We haven´t activated yet the translated pages. I´m still in the discover modus.
Nobody else is working on the site, but we do have a lot of visitors these days, with people searching for their holidays. So hope the site keeps working well!!

February 1, 2019 at 4:36 pm #3152453

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello - I just wanted to let you know that I am trying to install a reduced copy of your site onto a local server so that I can debug it locally without interrupting your site traffic.

Hopefully it will work! I will keep you updated h ere on my progress.

February 4, 2019 at 2:18 pm #3158026

judithV-7

Hi Yvette, how is it going? Can I turn of the debug mode on our website?

February 5, 2019 at 10:41 am #3161294

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Yes - you can.

I am installing and working off a local copy of your site.

February 5, 2019 at 11:18 am #3161426

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I´m having trouble getting the error to appear again.

This time, on my test system as well as on your site, I used the NL post:
hidden link

This is what I did:
1. I clicked on the "+" for English in the pages listing
2. This opened up the normal native editor.
3. I then clicked on the "Overwrite with Dutch Content" button on the sidebar
4. I then selected button "Translate Independently"
5. I changed the title and the slug (not really needed) and Updated the post.
6. I then opened the Zion builder for the post and changed the content of the translated post.
7. Published from Zion editor.

This created a translated page manually.
And I could then see the translated page.

Please see a screencast of these steps here on another post:
hidden link

So, which page are you getting the 500 error on? I will then focus on that particular page.
Thanks

February 5, 2019 at 2:33 pm #3162428

judithV-7

Hi Yvette,

if I try to do the same like you with the page ´huttentocht Spaanse Pyreneeen´ I get this page after I update the post (your step 5).

If I click on the +-icon for English for the page ´boutique pension spaanse pyreneeen´ in the pages listing, it opens in the Classic Editor, but shows only the title for translation (see first image).

Don´t know what to do, I´m getting really tired of all these problems, which seems to get worse instead of getting better. It seems it doesn´t want to work good. I don´t even want to think what´s going to happen if we change back the settings to language per domain and use the Classic Editor again! And that´s what we want. I really appreciate your help!! But don´t you also think that it looks like it´s impossible to get WPML working on our site??

Regards, Judith

February 5, 2019 at 3:12 pm #3162582

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Let me look one more time.
Hang in there.

February 5, 2019 at 3:26 pm #3162646

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Do you mean this page?
hidden link

I just opened the translation you made and edited it with no issues.

Am I opening up the wrong one?

February 5, 2019 at 6:06 pm #3163291

judithV-7

Yep, that´s the page. Don´t know, I got this weird page after updating it and now I see that in fact WPML translated the page.
If I click on the +-icon for English for the page ´boutique pension spaanse pyreneeen´ in the pages listing, it opens in the Classic Editor, but shows only the title for translation (see first image).

Can I try now if it´s works with the language per domains also? And the classic editor?

February 6, 2019 at 7:16 am #3164357

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

1. URL Format
Can I try now if it´s works with the language per domains also?
Yes - please. I have the local copy and so I can do tests locally. I will do same on my local copy.

2.Classic Editor
When you write the "classic editor" - are you referring to the "Classic Translation Editor"?

I believe we only turned it off to be able to "duplicate" the page in order to make sure all custom fields for layout/appearance so that the images appeared the same.

This should not cause issues. Again, I will try on my local system.

3. The Error
The error text includes: " MySQL server has gone away "
This is definitely a server condition. The error is stating that it could hand the data to store in the database to anything that will complete the task. The MySQL server is what manipulates the database. It seems that wordpress was able to resestablish the connection and complete the task so this is why I could then find the page translated.

Some relevant info I found here:
hidden link
https://wordpress.org/support/topic/warning-mysqli_query-mysql-server-has-gone-away/

I would suggest that you please check this error with the server support.

February 6, 2019 at 11:51 am #3165327

judithV-7

Hi Yvet,

1 language per domain
Changed to work with the language per domain (see image attached, did I click the checkboxes?). It seems to work (I still get this SQL-server problem but it completes the task). It tells me to ´save all the permalinks again´. Should I do this??

2. Classic Translation Editor
When I try to work with the ´Classic Translation Editor´ (see image attached, hope I did check the right checkboxes) I get this SQL-server problem page as well and it doesn´t let me work in the editor, so I turned it off again. It´s a shame because no I can´t use the Machine Translation Package which I bought.

3. SQL-page
I asked our webhosting company to look at the SQL-server problem. Is this a known problem, or is this something really strange, which means we have a bad server provider??

So, I keep on working now without the Classic Translation Editor but with the language per domain.

February 6, 2019 at 11:53 am #3165332

judithV-7

Sorry, forgot to upload the images..

February 6, 2019 at 12:13 pm #3165395

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

You questions:

1. . It tells me to ´save all the permalinks again´. Should I do this??
Answer: Yes, whenever you change the URL format, you need to resave the permalinks to avoid 404 errors. Please do this now.

2. Classic Translation Editor
The automatic machine translation is only available with "Advanced Translation Editor (ATE)". I will try this on my local machine to see if I get any errors.

3. SQL database is not found
I cannot comment, other than to say that the references to this error have always had some kind of server support resolve it.

February 6, 2019 at 2:25 pm #3166124

judithV-7

Hi,

1. ok, but where do I find the option to ´save all permalinks again´ without changing to work with language per domain? I already saved this option and now I don´t find the option to ´save all permalinks again´
2. I can´t use the advanced or classic translation editor because of this SQL-problem. Hope this will work after fixing the problem by our server support.
3. ok.

New problem: I´m translating pages manually like you described. But when I want to ´edit the page with pagebuilder´ opens the new page, but I can´t work in it with pagebuilder.

Regards