Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by patrickC-36 10 months, 3 weeks ago.

Assigned support staff: Andrés.

Author Posts
December 2, 2019 at 6:40 am #5050797

patrickC-36

Bonsoir,

Nous en avons profité pour changer de serveur vers ovh avec la version php 7.2 d'activé
J'ai donc fais la migration du site, mis à jour wordpress , et fais la la mise à jour du plug in wpml, mais je rencontre d'autre problèmes.

Voici les deux problèmes :
1/ Les langues apparaissent dans le header en plus du selecteur.... voir impression écran.

2/ Quand on clique sur un langue autre que le français, on atterris sur une erreur 404.
Toutes les pages traduites mènent vers des erreurs 404.

Merci de votre aide

December 2, 2019 at 6:43 am #5050829

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Par rapport à votre sélecteur de langues :

1. Pouvez-vous aller à WPML > Langues et vérifier de n'avoir pas sélectionné que l'option du sélecteur dans le menu ?

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Andrés

December 2, 2019 at 9:18 am #5051581

patrickC-36

Bonjour,
1/ j'ai essayé de supprimer le selecteur du menu et de le recréer, mais rien ne change. Les deux listes de langues sont toujours là.
2/ Je viens de voius fournir les informations de debug

December 2, 2019 at 9:49 am #5051943

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci d'avoir partagé votre information de débogage. Après votre code HTML, il semble que vous aviez ajouté deux trois fois notre sélecteur de langues :

1. Depuis les options WPML > Languages > Sélecteur de langues du menu.

2. Avec un shortcode (code PHP).

3. Avec un shortcode (code PHP).

Pouvez-vous éditer votre thème et effacer les shortcodes ajoutés ?

December 2, 2019 at 10:29 am #5052249

patrickC-36

Ok oui merci, j'avais ajouter ces shortcodes lors de ma première tentative d'installation, et j'ai oublié de les enlever. Merci.
Par contre, il reste toujours le soucis des erreurs 404, quand je vais sur une autre langue que le français...

December 2, 2019 at 10:31 am #5052255

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Parfait ! 🙂

Par rapport à nos règles de support, nous devons gérer un seul incident par ticket, ça nous permet d'améliorer notre service et permet à d'autres utilisateurs de bénéficier des informations exposées. Je dois vous demander d'ouvrir un autre pour nous concentrer sur cette nouvelle situation, vous pouvez me l'assigner directement et nous pouvons continuer à travailler ensemble sur ce sujet.

Cordialement

December 2, 2019 at 10:41 am #5052311

patrickC-36

ok merci

December 2, 2019 at 10:44 am #5052317

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Super ! 🙂
Belle journée.

December 3, 2019 at 11:07 am #5059877

patrickC-36

Bonjour,
j'ai crée un nouveau tickets qui vous est destiné, mais je n'ai toujours pas de réponse.
Merci

December 3, 2019 at 11:46 am #5060165

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci, mais comme le ticket n'a pas été assigné directement, il est allé à la queue général et il faudrait attendre un peu jusqu'à que le système me l'assigne.

Merci de votre compréhension.
Andrés

December 6, 2019 at 11:12 am #5083351

patrickC-36

My issue is resolved now. Thank you!