This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to Translate Mobile Menu. The desktop menu get translated after I translate pages that are designated in menu. But mobile menu and footer are not shown translated versions even when I translate footer or translate pages related to mobile menu.

Solution: Solution here: https://wpml.org/forums/topic/split-menu-not-appearing-on-mobile-view/#post-2784348

This topic contains 10 replies, has 3 voices.

Last updated by alexandraA-5 11 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
October 1, 2018 at 4:52 pm #2778884

alexandraA-5

Noman, hi,
What I am trying to: translate mobile menu. The decktop menu get translated after I translate pages that are designated in menu. But mobile menu and footer are not shown translated versions even when I translate footer or translate pages related to mobile menu

Link to a page where the issue can be seen: hidden link

I expected to see: mobile menu and footer to be translated

Instead, I got: russian language menu and footer

Could you please help?

October 2, 2018 at 7:14 pm #2782572

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Alexandra,

Just wanted to let you know that I am still working on this issue. Sorry for the delay, its been a loaded day for me. I will send you an update tomorrow as soon as possible.

Thank you for your cooperation and patience.

October 3, 2018 at 11:31 am #2784348

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have followed below steps in order to translate footer section:

- Restored English translation from Theme Panel >> My Library > Trash
- Selected ‘admin_texts_theme_mods_oceanwp’ domain from WPML >> String Translation >> “Select strings within domain:” dropdown.
- Then selected ‘[theme_mods_oceanwp]ocean_footer_widgets_template’ string and changed it’s language English to Russian from “Change the language of selected strings” dropdown
- Then added ID of the English footer translation as Russian footer translation and hit Save button as you can see in attached screenshot.

- To fixing visibility and layout issue on mobile, I have added following CSS in Appearance >> Customize >> Additional CSS section:

@media(max-width:767px){
#footer-widgets,
footer .elementor-hidden-phone {
display: block !important;
}
footer .elementor-row > .elementor-element {
float: none !important;
width: 100% !important;
}
.elementor-3245 .elementor-element.elementor-element-71b312c2 {
text-align: left !important;
}
footer .elementor-container {
max-width: 100% !important;
margin:0 !important;
}
}

And it looks as in attached screenshot.

Thank you

October 17, 2018 at 5:07 pm #2825439

alexandraA-5

Hi Noman,
Sorry for such late reply. Your code for footer partially works - the theme shows footer, but its empty (no words). So this footer problem still existis). I even created a new footer but now it works only on desctop vers., and shows no translatio(((.
And could you help me with translation of my page AQUA 2 (АКВА 2). When I'm trying to translate it - the WPML editor shows an empty page. Why is it so? Could you please help me)

October 17, 2018 at 6:34 pm #2825654

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

I would like to take care of your ticket from now. Thanks for following Noman instructions, in that case, I'll need to double-check your site but I do not have access to your site.

Please, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 19, 2018 at 10:55 am #2831686

alexandraA-5

And it's strange that on pages that are already translated in Eng all links lead to russian pages...what did I do wrong?)

October 20, 2018 at 1:31 am #2833288

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. From what I noticed, this menu was not created in the secondary language. When I click on Appearance > Menus, I see that the Russian menu is not translated.

You must translate it so that the menu is displayed in the secondary language. At the moment I noticed that you have some menu pages already translated, so you can just sync the menu by clicking on Appearance > Menus > "Synchronize menus between languages". I'll attach an image for you to see.

You can see a little more in our documentation: https://wpml.org/documentation/getting-started-guide/translating-menus/. Synchronizing the menu, does the problem persist?

Thank you.

October 23, 2018 at 1:36 pm #2842644

alexandraA-5

Hey ther),
Bruno, oh..the problem is still here(. I attach images.
Help)), please.

October 24, 2018 at 10:48 am #2845852

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have updated WPML plugins in your site and just saved menus in English and it looks fine as in attached screenshot.

Thank you

October 26, 2018 at 1:40 pm #2853152

alexandraA-5

Hi Noman! Hi Bruno!
I just can't belive my eyes!!! It's working! Thank you!!

October 26, 2018 at 1:41 pm #2853154

alexandraA-5

My issue is resolved now. Thank you!