This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by itaiA-2 2 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 18, 2019 at 8:09 pm #4242211

itaiA-2

Also: while you're looking at my site. See the little red dot to the right of 'info' on my nav bar?

When I activate the french language I get 2 of those. They're clickable and they take up space. Even when I only configure a dropdown menu, I see them on top of the dropdown menu.

July 18, 2019 at 8:19 pm #4242217

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

I took a look at the "dot" issue and noticed that these "dots" seem to be flag imgs , their links take you to the translated version of the site.

for example French is currently set to Hidden , in order to view it you have to go to Your Profile->Edit Profile-> enable "display hidden languages"

once i did that i was able to see the second "dot" that leads to the FR version.

This language switcher seems to be added by some custom code
av-language-switch-item language_en avia_current_lang

hidden link

seems like the CDN in the front of the URL is causing issues as the URL to the correct flag should be hidden link

July 19, 2019 at 4:59 pm #4247581

itaiA-2

Thanks for fixing the currency issue Bobby.

Now about those flags: I have selected not to have ANY flags in my menu, yet they appear horizontally as mini-flags.

Even if I choose to have a dropdown, I get the dropdown languages AND these flag horizontal menu. I want to get rid of the flags.

What am I supposed to do?

Cheers,

I

July 19, 2019 at 5:28 pm #4247631

itaiA-2

Nevermind, it was a theme issue -Enfold theme

For those looking for the answer, add this to your child CSS:

/* hide Enfold menu flags */
.av-language-switch-item{
display:none!important;
}
#av-burger-menu-ul .wpml-ls-slot-26{
display:none!important;
}

Cheers

July 19, 2019 at 5:28 pm #4247637

itaiA-2

My issue is resolved now. Thank you!